после смены сервера не работают всплывающие элементы, IPB 3.3.4 - Дизайн и модификация Invision Power Board

Перейти к содержимому

 

Правила раздела

Здесь обсуждаются вопросы по настройке и администрированию форумов IPB 3.x.
Пожалуйста, не оффтопьте, если зашли сюда случайно, и обратите внимание на соседние разделы.
Установка, настройка и обслуживание форумов IPB 2.x.
Оформление форумов, включая верстку скинов.
Размещение рекламы на форумах.
SEO оптимизация форума.
Техническая поддержка наших скинов и модов.

СвернутьПрикрепленные теги

Теги не найдены

Страница 1 из 1

после смены сервера не работают всплывающие элементы, IPB 3.3.4

#1 Пользователь не на сайте   magnumspec ответил: »

 
 
  • Newbie
  • *
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 8
  • Регистрация: 19-Октябрь 12
  • Репутация: 0
  • IPB version:3.4.x
 

Отправлено 20 Апрель 2013 - 11:50

Суть в следующем, неделю назад хостер перенес данные сайта на другой сервер. Перестали работать разного рода всплывающие элементы:
- при создании поста не появляются опции редактора (шрифт, ссылки и т.д.)
- при нажатии на "Вход" не всплывает меню, а открывается отдельная страница
- в чат не добавляются посты
- не работает всплывающее меню смены стиля
- действие кнопки "вверх" в самом низу страницы мгновенно, хотя должно происходить плавно
- а так же несколько неверно отображается меню в шапке
возможно что-то еще, чего пока не заметил.
*как ни странно, но содержимое пункта меню "More" в шапке работает.

Еще странне то, что только у меня в Firefox этих проблем нет, т.е. каким-то образом браузер сохранил то, что было... Поэтому так долго не замечал проблему.

Включал лог ошибок и проводил описанные действия в других браузерах - ничего не указывалось.
Подключал другой шаблон - проблемы оставались.

Прошу, помогите пожалуйста, как эту проблему решить. Размышляю над тем, что возможно при переносе сайта хостером на сервер не докачались какие-то файлы, но не представляю, какие именно.
Переустанавливать форум не хочу, уж слишком много было ручных изменений и танцев с бубном в процессе...
0

#2 Пользователь не на сайте   Bot ответил: »

 
 
  • Почетный робот
  • ***
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
 

Отправлено 20 Апрель 2013 - 11:50

Обратите внимание

По указанному вами в профиле "Board url" находится не IP.Board, либо модифицированный пиратский скрипт с удаленными копирайтами. Если вы указали неверный URL, пожауйста, поправьте его, потому что он скорее всего потребуется при диагностике вашей проблемы. Нелицензионные скрипты не приветствуются, т.к. зачастую именно некорректное "нуление" и является причиной проблем в них.


0

#3 Пользователь не на сайте   Zero108 ответил: »

 
 
  • Advanced
  • ***
  • Смотреть галерею
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 1 562
  • Регистрация: 25-Июль 09
  • Репутация: 92
  • IPB version:4.1.x
 

Отправлено 20 Апрель 2013 - 14:21

Возможно, вам следует проверить архивную папку с файлами форума и рабочую папку форума на предмет того, что все файлы были перенесены.

Также проверить с помощью утилиты, прилагаемой к дистрибутиву форума, что конфигурация сервера удовлетворяет минимальным требованим.

Затем проверить, что права CHMOD на папки и подпапки форума, а также некоторые файлы выставлены правильно.

Затем перекешировать все стили и перекешировать общий кеш.

Если ничего из вышеперечисленного не помогает, переустановить форум или обратиться в службу технической поддержки IPS.

Также перед тестированием сделать полную очистку кеша браузера.

Сообщение изменено: Zero108 (20 Апрель 2013 - 15:12)

0

#4 Пользователь не на сайте   Dmitriy427 ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Specialist
  • Сообщений: 574
  • Регистрация: 15-Октябрь 11
  • Репутация: 152
  • Откуда:Россия, Тула
  • IPB version:3.3.x
 

Отправлено 20 Апрель 2013 - 15:37

Указывайте в профиле адрес форума. Медиумов здесь нет, а гадание по форме облаков даёт скверный результат обычно.
0

#5 Пользователь не на сайте   magnumspec ответил: »

 
 
  • Newbie
  • *
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 8
  • Регистрация: 19-Октябрь 12
  • Репутация: 0
  • IPB version:3.4.x
 

Отправлено 20 Апрель 2013 - 16:06

Адрес в профиле указан.

Проверил, конфигурация удовлетворяет всем требованиям. Права выставил согласно файлу из дистрибутива (были везде 777). Сбросил общий кэш и кэш скинов. Без изменений.

В техподдержке хостинга предлагают перенести аккаунт на другой сервер, вдруг поможет, стоит ли, учитывая что по требованиям текущий сервер подходит?
0

#6 Пользователь не на сайте   Dmitriy427 ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Specialist
  • Сообщений: 574
  • Регистрация: 15-Октябрь 11
  • Репутация: 152
  • Откуда:Россия, Тула
  • IPB version:3.3.x
 

Отправлено 20 Апрель 2013 - 17:22

Просмотреть сообщениеmagnumspec 20 Апрель 2013 - 16:06 сказал(а):

Адрес в профиле указан.
Если указан в поле "Board URL", то его видите только вы и администрация ipbskins.ru, которая всем отвечать не успевает, надо думать. Продублируйте адрес в поле "Website URL" или ждите когда siv1987 сюда заглянет.
0

#7 Пользователь на сайте   siv1987 ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins Team
  • Сообщений: 8 720
  • Регистрация: 20-Март 09
  • Репутация: 2 269
  • IPB version:3.1.x
 

Отправлено 20 Апрель 2013 - 17:44

Проблема скорее всего была с кешем, так как файл прототайпа был пустой. Сейчас он уже грузиться нормально.
Для папки /cache/ должны стоять права на запись.
0

#8 Пользователь не на сайте   magnumspec ответил: »

 
 
  • Newbie
  • *
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 8
  • Регистрация: 19-Октябрь 12
  • Репутация: 0
  • IPB version:3.4.x
 

Отправлено 20 Апрель 2013 - 17:50

Ясно.
Проблему решил просто перезалив файлы из дистрибутива с заменой. Т.е. проблема крылась в повреждении какого-то файла.
0

Сообщить об этой теме:


Страница 1 из 1


Быстрый ответ

  

1 пользователей читают эту тему
0 зарегистрированных, 1 гостей, 0 скрытых


Контактная информация

Вопросы по работе сайта

+7 (917) 501-4765
C 10 до 20 в рабочие дни (время московское)

Техническая поддержка

Контактные данные специалистов

Дизайн форумов

IPB 3.x ¦ IPB 2.x

Бесплатные шаблоны

IPB 3.2 – 3.4 ¦ IPB 3.1 ¦ IPB 3.0 ¦ IPB 2.2 – 2.3 ¦ IPB 2.1 ¦ Клипарт
Лицензия на использование ¦ Ваша поддержка ¦ О проекте
Copyright © 2005-2016 IPBSkins.ru Team
При копировании материалов с сайта
прямая ссылка на источник обязательна