404-е после смены хостинга - Дизайн и модификация Invision Power Board

Перейти к содержимому

 

Правила раздела

Здесь обсуждаются вопросы по настройке и администрированию форумов IPB 3.x.
Пожалуйста, не оффтопьте, если зашли сюда случайно, и обратите внимание на соседние разделы.
Установка, настройка и обслуживание форумов IPB 2.x.
Оформление форумов, включая верстку скинов.
Размещение рекламы на форумах.
SEO оптимизация форума.
Техническая поддержка наших скинов и модов.

СвернутьПрикрепленные теги

ошибка 404

Страница 1 из 1

404-е после смены хостинга

#1 Пользователь не на сайте   wcp ответил: »

 
 
  • Member
  • **
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 87
  • Регистрация: 23-Октябрь 07
  • Репутация: 0
  • IPB version:3.4.x
 

Отправлено 22 Август 2014 - 18:43

Господа, чую что ошибка где-то рядом, но двое суток без сна и слезящиеся глаза дают о себе знать.

Клиент попросил перенести форум на vds. Все сделал, конфиг поправил, база на месте.
Главная страница грузится, все остальные ссылки - 404.
Админка ругнулась только не неверный путь к uploads/profile, исправил, больше ошибок не было.
0

#2 Пользователь не на сайте   wcp ответил: »

 
 
  • Member
  • **
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 87
  • Регистрация: 23-Октябрь 07
  • Репутация: 0
  • IPB version:3.4.x
 

Отправлено 22 Август 2014 - 18:55

сам спросил - сам ответил ) htaccess потерялся при переносе (был скрыт и я про него просто забыл)
0

#3 Пользователь не на сайте   siv1987 ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins Team
  • Сообщений: 8 763
  • Регистрация: 20-Март 09
  • Репутация: 2 288
  • IPB version:3.1.x
 

Отправлено 22 Август 2014 - 19:00

404 Not found - это проблемы с чпу.
  • Проверить в .htaccess путь по которому реврайтятся ссылки. На старом хостинге форум мог быть в папке /forum/, на новом он в корне домена, а урл все еще реврайтятся по старому на /forum/index.php.
  • Проверить наличие mod_rewrite на сервере
  • Проверить если веб-сервер Apache, если нет - сконфигурировать реврайт согласно своему серверу (nginx, lighttpd etc).
  • Отключить в настройках АЦ -> Поисковая оптимизация - Использовать mod_rewrite

1

Сообщить об этой теме:


Страница 1 из 1


Быстрый ответ

  

1 пользователей читают эту тему
0 зарегистрированных, 1 гостей, 0 скрытых


Контактная информация

Вопросы по работе сайта

+7 (917) 501-4765
C 10 до 20 в рабочие дни (время московское)

Техническая поддержка

Контактные данные специалистов

Дизайн форумов

IPB 3.x ¦ IPB 2.x

Бесплатные шаблоны

IPB 3.2 – 3.4 ¦ IPB 3.1 ¦ IPB 3.0 ¦ IPB 2.2 – 2.3 ¦ IPB 2.1 ¦ Клипарт
Лицензия на использование ¦ Ваша поддержка ¦ О проекте
Copyright © 2005-2016 IPBSkins.ru Team
При копировании материалов с сайта
прямая ссылка на источник обязательна