Постоянно слетает ключ лицензии - Дизайн и модификация Invision Power Board

Перейти к содержимому

 

Правила раздела

Здесь обсуждаются вопросы по настройке и администрированию форумов IPB 3.x.
Пожалуйста, не оффтопьте, если зашли сюда случайно, и обратите внимание на соседние разделы.
Установка, настройка и обслуживание форумов IPB 2.x.
Оформление форумов, включая верстку скинов.
Размещение рекламы на форумах.
SEO оптимизация форума.
Техническая поддержка наших скинов и модов.

СвернутьПрикрепленные теги

Теги не найдены

Страница 1 из 1

Постоянно слетает ключ лицензии

#1 Пользователь не на сайте   Alien2001 ответил: »

 
 
  • Member
  • **
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 92
  • Регистрация: 26-Июль 12
  • Репутация: 10
  • IPB version:3.3.x
 

Отправлено 11 Апрель 2016 - 17:50

Просто замучился. В последние пару месяцев постоянно слетает ключ лицензии: захожу в админку, а сверху красное объявление "Отсутствует ключ лицензии". Ввожу его заново, неделю где-то все нормально, а потом опять то же самое.

Лицензия у меня неактивная - купил в 2013 году, один раз обновил, а потом понял, что в этом нет никакого смысла - про выход IPCS 4 они постоянно врали, а в результате выпустили ее на год позже обещанного. Сейчас установлена версия 3.3.4. Сегодня написал в техподдержку и получил такой ответ:



Цитата

Hello, there are two issues here causing this, once is you are on an out dated version, you would need to upgrade to at least 3.4.9 to fix this if not the all new IPS 4.1.
The second is the license is expired, you can use this guide here to re-activate the license, then you can upgrade as above.



Они предлагают мне обновиться как минимум до версии 3.4.9 или реактивировать лицензию. Но мне не нужно ни то, ни другое. Во-первых, на версию 3.4.9 я не имею права - лицензия закончилась раньше, чем ее выпустили. А кроме того, я не хочу этого делать - у меня стоит куча модов и допилов форума (пожалуй, тут все знают, насколько кривой и безобразный у IPS код, из которого постоянно лезут всякие глюки, и это, блин, коммерческий продукт!). Во-вторых, я не хочу реактивировать лицензию - это значит надо снова им платить, непонятно за что. Как я понимаю, по условиям лицензии, я имею право пожизненно использовать последнюю вышедшую в период действия лицензии версию IPB и более старые.

Ответ пришел быстро, но носит характер откровенной отписки - они просто не разбирались в ситуации вообще. Непонятно, что все-таки делать с этой слетевшей лицензией, не вводить же ее каждый раз заново


0

#2 Пользователь не на сайте   siv1987 ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins Team
  • Сообщений: 8 763
  • Регистрация: 20-Март 09
  • Репутация: 2 288
  • IPB version:3.1.x
 

Отправлено 11 Апрель 2016 - 18:16

Просмотреть сообщениеAlien2001 сказал(а):

Но мне не нужно ни то, ни другое.

К сожалению вам действительно нужно обновится до последней версии, потому что там есть критические уязвимости. Или хотябы установить все secutiry updates после выпуска этой версии. В последнее время по моему она вообще больше не поддерживалась.

Просмотреть сообщениеAlien2001 сказал(а):

пожалуй, тут все знают, насколько кривой и безобразный у IPS код, из которого постоянно лезут всякие глюки, и это, блин, коммерческий продукт!

Я бы не сказал что код прямо так уж и кривой. Покажите тогда пример кмс с "нормальным кодом"? Или, если вы думаете что багов нету, то код весь такой прекрасный? Глюки лезут из-за логики в коде.

Просмотреть сообщениеAlien2001 сказал(а):

Непонятно, что все-таки делать с этой слетевшей лицензией

А чем она вам мешает? Уберите уведомление да и все.
0

#3 Пользователь не на сайте   Alien2001 ответил: »

 
 
  • Member
  • **
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 92
  • Регистрация: 26-Июль 12
  • Репутация: 10
  • IPB version:3.3.x
 

Отправлено 11 Апрель 2016 - 18:30

Просмотреть сообщениеsiv1987 11 Апрель 2016 - 18:16 сказал(а):

К сожалению вам действительно нужно обновится до последней версии, потому что там есть критические уязвимости. Или хотябы установить все secutiry updates после выпуска этой версии.


Все secutiry updates у меня установлены. Более того, теперь стараюсь следить и за апдейтами 3.4 - там во многом похожий код и закрывать эти уязвимости. Но на последнюю версию я не имею права по условиям лицензии. Кстати, как я понимаю, здесь вообще версия 3.2 стоит и ничего.


Меня возмущает сам наплевательский подход IPS к к клиенту: по условиям лицензии я имею право использовать старые версии, и у меня ничего не должно вылетать, я не должен прыгать с бубном, чтобы это сообщение скрыть.

Цитата

А чем она вам мешает? Уберите уведомление да и все.

Я видел эту тему, но хотел решить все цивилизованным путем. А так получается, будто у меня нелицензионный продукт стоит, нулевка практически.
0

#4 Пользователь не на сайте   siv1987 ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins Team
  • Сообщений: 8 763
  • Регистрация: 20-Март 09
  • Репутация: 2 288
  • IPB version:3.1.x
 

Отправлено 11 Апрель 2016 - 18:56

Просмотреть сообщениеAlien2001 сказал(а):

А так получается, будто у меня нелицензионный продукт стоит, нулевка практически.

Не надо сравнивать нулл с сокрытием блока в css. Это разные вещи. Вам никто не запрещает пользоваться старыми версиями.

Просмотреть сообщениеAlien2001 сказал(а):

Кстати, как я понимаю, здесь вообще версия 3.2 стоит и ничего

Здесь 3.1 и все патчи мы устанавливаем вручную.
0

#5 Пользователь не на сайте   Атаман ответил: »

 
 
  • Advanced
  • Смотреть блог
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins.ru Team
  • Сообщений: 2 154
  • Регистрация: 13-Апрель 12
  • Репутация: 327
  • Откуда:no
  • IPB version:1.x
 

Отправлено 11 Апрель 2016 - 20:00

Можете попросить у кого-то 3.4.9 retail - без проблем обновитесь, и после обновы введите ключ в АЦ.
0

#6 Пользователь не на сайте   siv1987 ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins Team
  • Сообщений: 8 763
  • Регистрация: 20-Март 09
  • Репутация: 2 288
  • IPB version:3.1.x
 

Отправлено 11 Апрель 2016 - 20:09

Просмотреть сообщениеАтаман сказал(а):

Можете попросить у кого-то 3.4.9 retail - без проблем обновитесь

...а все остальное на свой страх и риск.
0

#7 Пользователь не на сайте   Атаман ответил: »

 
 
  • Advanced
  • Смотреть блог
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins.ru Team
  • Сообщений: 2 154
  • Регистрация: 13-Апрель 12
  • Репутация: 327
  • Откуда:no
  • IPB version:1.x
 

Отправлено 11 Апрель 2016 - 20:17

Просмотреть сообщениеsiv1987 11 Апрель 2016 - 20:09 сказал(а):

...а все остальное на свой страх и риск.


Но-это решит большинство проблем. Но потратить 25 уе на продление анти-спама и доступа к дистрибутивам + поддержке, всё на пол года (включая к 4). Перестраховка для топикстартера от неурядиц.
0

#8 Пользователь не на сайте   Alien2001 ответил: »

 
 
  • Member
  • **
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 92
  • Регистрация: 26-Июль 12
  • Репутация: 10
  • IPB version:3.3.x
 

Отправлено 12 Апрель 2016 - 12:10

Просмотреть сообщениеsiv1987 11 Апрель 2016 - 18:56 сказал(а):

Здесь 3.1 и все патчи мы устанавливаем вручную.


У вас тоже ключ лицензии слетает постоянно?
0

#9 Пользователь не на сайте   Alien2001 ответил: »

 
 
  • Member
  • **
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 92
  • Регистрация: 26-Июль 12
  • Репутация: 10
  • IPB version:3.3.x
 

Отправлено 12 Апрель 2016 - 12:17

Просмотреть сообщениеАтаман 11 Апрель 2016 - 20:17 сказал(а):

Но-это решит большинство проблем. Но потратить 25 уе на продление анти-спама и доступа к дистрибутивам + поддержке, всё на пол года (включая к 4). Перестраховка для топикстартера от неурядиц.


Я никогда не пользовался их антиспамом, считаю его совершенно бесполезным. У меня есть собственный механизм борьбы со спаммерами, и он достаточно эффективен. Так что спам у меня на форуме бывает только "ручной", когда нас где-нибудь на адвего заказывают.

Мне не жалко 25 уе, если бы они реально дали что-то полезное. Но чтобы обновиться до 3.4 или 4.1, нужно будет потратить слишком много сил, а оно того коммерчески в данный момент не стоит.


0

#10 Пользователь не на сайте   siv1987 ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins Team
  • Сообщений: 8 763
  • Регистрация: 20-Март 09
  • Репутация: 2 288
  • IPB version:3.1.x
 

Отправлено 12 Апрель 2016 - 18:24

Честно говоря не знаю. Во всяком случае уведомления как в 3.3 нету, но надо посмотреть как это реализовано в 3.1, по моему этот блок добавили позже.
0

#11 Пользователь не на сайте   avgaz ответил: »

 
 
  • Advanced
  • ***
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 153
  • Регистрация: 28-Январь 08
  • Репутация: 5
  • IPB version:3.4.x
 

Отправлено 16 Апрель 2016 - 01:06

Просмотреть сообщениеАтаман 11 Апрель 2016 - 20:17 сказал(а):

Но-это решит большинство проблем. Но потратить 25 уе на продление анти-спама и доступа к дистрибутивам + поддержке, всё на пол года (включая к 4). Перестраховка для топикстартера от неурядиц.

То есть если у меня была лицензия на 3.4 которая закончилась уже давненько я за 25$ могу получить лиц 4.1?
0

#12 Пользователь не на сайте   Атаман ответил: »

 
 
  • Advanced
  • Смотреть блог
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins.ru Team
  • Сообщений: 2 154
  • Регистрация: 13-Апрель 12
  • Репутация: 327
  • Откуда:no
  • IPB version:1.x
 

Отправлено 16 Апрель 2016 - 08:17

Да.
У Ips Вы продлеваете поддержку и доступ к обновлениям за 25 уе (на пол года).
Лицензия вечная.
1

Сообщить об этой теме:


Страница 1 из 1


Быстрый ответ

  

1 пользователей читают эту тему
0 зарегистрированных, 1 гостей, 0 скрытых


Контактная информация

Вопросы по работе сайта

+7 (917) 501-4765
C 10 до 20 в рабочие дни (время московское)

Техническая поддержка

Контактные данные специалистов

Дизайн форумов

IPB 3.x ¦ IPB 2.x

Бесплатные шаблоны

IPB 3.2 – 3.4 ¦ IPB 3.1 ¦ IPB 3.0 ¦ IPB 2.2 – 2.3 ¦ IPB 2.1 ¦ Клипарт
Лицензия на использование ¦ Ваша поддержка ¦ О проекте
Copyright © 2005-2016 IPBSkins.ru Team
При копировании материалов с сайта
прямая ссылка на источник обязательна