Ошибка при обновлении - Дизайн и модификация Invision Power Board

Перейти к содержимому

 

СвернутьПрикрепленные теги

Теги не найдены

Страница 1 из 1

Ошибка при обновлении

#1 Пользователь не на сайте   9IPOCTb ответил: »

 
 
  • Advanced
  • ***
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 264
  • Регистрация: 28-Август 16
  • Репутация: 2
  • IPB version:3.4.x
 

Отправлено 11 Октябрь 2017 - 06:13

Приветствую уважаемые форумчане.

При обновлении форума с 3.4.х версии до 4.х на странице обновлении на втором этапе выдает ошибку:

syntax error, unexpected 'System' (T_STRING), expecting '{'

подскажите как исправить данную ошибку?
0

#2 Пользователь не на сайте   newbie ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins.ru Team
  • Сообщений: 3 254
  • Регистрация: 26-Октябрь 11
  • Репутация: 1 322
  • IPB version:I have no IPB
 

Отправлено 11 Октябрь 2017 - 08:39

Просмотреть сообщение9IPOCTb сказал(а):

syntax error, unexpected 'System' (T_STRING), expecting '{'

Это все? Нет указания на файл, где произошла ошибка?
Попробуйте перезалить файлы.
1

#3 Пользователь не на сайте   9IPOCTb ответил: »

 
 
  • Advanced
  • ***
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 264
  • Регистрация: 28-Август 16
  • Репутация: 2
  • IPB version:3.4.x
 

Отправлено 11 Октябрь 2017 - 18:18

да, это все http://prntscr.com/gw4785
пробывал 4.2.2 ставить и 4.1.19.4 одна и та же ошибка
0

#4 Пользователь не на сайте   newbie ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins.ru Team
  • Сообщений: 3 254
  • Регистрация: 26-Октябрь 11
  • Репутация: 1 322
  • IPB version:I have no IPB
 

Отправлено 12 Октябрь 2017 - 09:27

Посмотрите в логах. Или дайте доступ к обновлению, чтобы продебажить.
1

#5 Пользователь не на сайте   9IPOCTb ответил: »

 
 
  • Advanced
  • ***
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 264
  • Регистрация: 28-Август 16
  • Репутация: 2
  • IPB version:3.4.x
 

Отправлено 16 Февраль 2018 - 23:36

опять данная ошибка ((((

Сообщение изменено: 9IPOCTb (16 Февраль 2018 - 23:37)

0

#6 Пользователь не на сайте   newbie ответил: »

 
 
  • Advanced
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins.ru Team
  • Сообщений: 3 254
  • Регистрация: 26-Октябрь 11
  • Репутация: 1 322
  • IPB version:I have no IPB
 

Отправлено 17 Февраль 2018 - 09:13

Просмотреть сообщение9IPOCTb сказал(а):

опять данная ошибка ((((

Я могу продублировать свое предыдущее сообщение.

Просмотреть сообщениеnewbie сказал(а):

Посмотрите в логах. Или дайте доступ к обновлению, чтобы продебажить.

0

#7 Пользователь не на сайте   BaMIIuP ответил: »

 
 
  • Newbie
  • *
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 6
  • Регистрация: 02-Май 16
  • Репутация: 0
  • IPB version:3.3.x
 

Отправлено 09 Апрель 2018 - 23:42

А можно подробную инструкцию как обновиться с 3.4.х версии до 4.х ,в интернете толком ничего нет а что есть то ничего не понятно
0

#8 Пользователь не на сайте   Zero108 ответил: »

 
 
  • Advanced
  • ***
  • Смотреть галерею
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 1 758
  • Регистрация: 25-Июль 09
  • Репутация: 112
  • IPB version:4.1.x
 

Отправлено 10 Апрель 2018 - 11:48

1. Делаете резервную копию папки сайта и базы данных.
2. Удаляете все папки и файлы, кроме папки uploads.
3. Копируете в папку сайта установочные файлы.
4. Запускаете в браузере апгрейд командой http://www.site.ru/admin/upgrade/ , где http://www.site.ru/ - адрес вашего сайта, а admin/ - директория админцентра.
5. Смотрите, есть ли проблемы с совместимостью (выделено красным), исправляете в настройках сервера. Затем смотрите, какие ошибки при установке и пишите сюда.

Примечание: перед установкой базу данных лучше всего очиситить от кэш-файлов (почистить cache файлы через клик кнопки в админке). Если форум достаточно большой, то пересчет данных при апгрейде может затянуться на несколько дней.

Перед установкой желательно проверить локаль сервера командой locale по ssh, а также проверить кодировку базы данных вашего текущей версии в phpmyadmin и в конфиге движка IPB 3. Если они отличаются в каком-то месте от UTF-8, то могут быть проблемы с кодировкой после и во время апгрейда. В IPB 3 таблицы создаются в той кодировке, которая указана при создании базы данных (если она задана, в противном случае также будет использоваться кодировка в которой работает сервер), а вот кодировка соединения (set names) по умолчанию отсутствует в конфиге форума, и при соединение с сервером используется дефолтная кодировка mysql сервера. Если mysql сервер работает не в utf8 при установке IPB с кириллическими буквами, начинается каша.

Суммируя сказанное, локаль сервера должна быть UTF-8. Базу данных перед апгрейдом лучше проверить и конвертировать в UTF-8 unicode, даже если было general, не говоря уже о других кодировках. В идеале должно получится, что база данных переконвертирована (данные в таблицах хранятся в UTF-8, сами таблицы в UTF-8 general), соединение с базой данных в UTF-8 (в движке IPS 4 это по умолчанию), а на самом сервере локаль UTF-8:

# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Сообщение изменено: Zero108 (10 Апрель 2018 - 12:53)

3

#9 Пользователь не на сайте   Атаман ответил: »

 
 
  • Advanced
  • Смотреть блог
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: IPB Skins.ru Team
  • Сообщений: 2 531
  • Регистрация: 13-Апрель 12
  • Репутация: 396
  • Откуда:no
  • IPB version:1.x
 

Отправлено 10 Апрель 2018 - 13:55

Цитата

2. Удаляете все папки и файлы, кроме папки uploads.

Нельзя. Просто поверх, смайлы и тд не сконвертирует.
0

#10 Пользователь не на сайте   Zero108 ответил: »

 
 
  • Advanced
  • ***
  • Смотреть галерею
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 1 758
  • Регистрация: 25-Июль 09
  • Репутация: 112
  • IPB version:4.1.x
 

Отправлено 10 Апрель 2018 - 14:41

Ну, из бекапа потом картинки залить, чем хранить кучу ненужных файлов от старого движка. Если дело только в картинках.

Сообщение изменено: Zero108 (10 Апрель 2018 - 14:41)

0

#11 Пользователь не на сайте   BaMIIuP ответил: »

 
 
  • Newbie
  • *
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 6
  • Регистрация: 02-Май 16
  • Репутация: 0
  • IPB version:3.3.x
 

Отправлено 10 Апрель 2018 - 22:33

Я оставил папку uploads и файл conf_global.php залил версию ips_4.2.8
Конвертировал базу данных
Вложение  2018-04-10_22-44-45.png (20,04К)
Количество загрузок: 9 Вложение  2018-04-10_22-45-22.png (24,89К)
Количество загрузок: 13
Перехожу на /admin/upgrade/ там просит логин пароль ввожу от своей админки и не подходит
Вложение  2018-04-10_22-31-40.png (19,76К)
Количество загрузок: 13

Сообщение изменено: BaMIIuP (10 Апрель 2018 - 23:10)

0

#12 Пользователь не на сайте   Zero108 ответил: »

 
 
  • Advanced
  • ***
  • Смотреть галерею
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 1 758
  • Регистрация: 25-Июль 09
  • Репутация: 112
  • IPB version:4.1.x
 

Отправлено 11 Апрель 2018 - 04:18

Содержимое таблиц не в utf8. Возможно, после конвертации данные логина и пароля хранятся неправильно. Я бы посоветовал переконвертировать содержимое таблиц. А потом конвертировать саму базу данных, удостоверившись, что на сервере локаль utf8.
0

#13 Пользователь не на сайте   Zero108 ответил: »

 
 
  • Advanced
  • ***
  • Смотреть галерею
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 1 758
  • Регистрация: 25-Июль 09
  • Репутация: 112
  • IPB version:4.1.x
 

Отправлено 16 Апрель 2018 - 15:49

Цитата

логин пароль ввожу от своей админки и не подходит


Вот это еще проверьте:

Цитата

Баг нашел и исправил. Оказывается, если в БД будут еще лежать таблицы с именами core_members, то дистриб при обновлении туда лезет пользователей смотреть. А оно осталось от одной из страх инсталляций. После зачистки левых таблиц все прошло удачно.

Сообщение изменено: Zero108 (16 Апрель 2018 - 15:50)

0

#14 Пользователь не на сайте   BaMIIuP ответил: »

 
 
  • Newbie
  • *
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 6
  • Регистрация: 02-Май 16
  • Репутация: 0
  • IPB version:3.3.x
 

Отправлено 23 Апрель 2018 - 19:25

Вообщем ничего не вышло у меня, почему то так и не хочет логиниться,видно не могу как надо конвертировать базу данных,создавал форум с нуля ipb 3.9 и пробовал обновлять на ips 4.2 все идеально обновилось без проблем ,а с моей базой не хочет
0

#15 Пользователь не на сайте   Zero108 ответил: »

 
 
  • Advanced
  • ***
  • Смотреть галерею
  • Insert nick to fast reply form
  • Quote selected text to fast reply form
  • Группа: Пользователи
  • Сообщений: 1 758
  • Регистрация: 25-Июль 09
  • Репутация: 112
  • IPB version:4.1.x
 

Отправлено 23 Апрель 2018 - 22:45

Создайте несколько админов до обновленния. Попробуйте сменить группу админов в конфиге. Хоть к одному пользователю должен подойти пароль.
0

Сообщить об этой теме:


Страница 1 из 1


Быстрый ответ

  

1 пользователей читают эту тему
0 зарегистрированных, 1 гостей, 0 скрытых


Контактная информация

Вопросы по работе сайта

+7 (917) 501-4765
C 10 до 20 в рабочие дни (время московское)

Техническая поддержка

Контактные данные специалистов

Дизайн форумов

IPB 3.x ¦ IPB 2.x

Бесплатные шаблоны

IPB 3.2 – 3.4 ¦ IPB 3.1 ¦ IPB 3.0 ¦ IPB 2.2 – 2.3 ¦ IPB 2.1 ¦ Клипарт
Лицензия на использование ¦ Ваша поддержка ¦ О проекте
Copyright © 2005-2018 IPBSkins.ru Team
При копировании материалов с сайта
прямая ссылка на источник обязательна