Jump to content

Фикс PHP для старого движка


Trotor
 Share

Recommended Posts

Есть небольшой форум на древнем движке ipb 1.3, который стоит на сабдомене. Недавно переехал на новый хостинг, на нём стоит последняя версия PHP.

При заходе на этот форум, не открывались страницы на нём, выкидывало на главную.

Нашёл способ лечения такого, в index.php добавил:

// php4 compatible
$HTTP_POST_VARS   = $_POST;

Проблема решилась.

Но осталась ещё одна - при открытии тем, отображается белая страница.

Как это вылечить? Какой то есть ещё фикс?

 

Обновить на более новую версию не предлагать, форум маленький, на нём мало людей.

Link to comment
Share on other sites

Обратите внимание

По указанному вами в профиле "Board url" находится не IP.Board, либо модифицированный пиратский скрипт с удаленными копирайтами. Если вы указали неверный URL, пожауйста, поправьте его, потому что он скорее всего потребуется при диагностике вашей проблемы. Нелицензионные скрипты не приветствуются, т.к. зачастую именно некорректное "нуление" и является причиной проблем в них.

Link to comment
Share on other sites

Сначала надо посмотреть логи, выявить причину, а потом уже предлагать варианты лечения. С последней версией у 1.3 очень много несовместимостей будет, если даже у 2x они имеются

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...