Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Squipy

Проблемы с Входом на сайт 3.1.4

Recommended Posts

Доброго времени суток

вчера перенес свой форум на новый хостинг

и вот что получилось при нажатии на любую переносную ссылку получалось белое молоко точнее ничего не происходило.

её решил но.. не могу зайти на форум под аккаунтом)

вот что происходит

кликаю на кнопку "вход" ввожу логины пароли)

и вуаля

 

"Вы вошли в систему!

Подождите, сейчас Вы будете перенаправлены

(Или нажмите сюда, если не хотите ждать)"

но не тут то было, входа не было,в смысле страница обновляется и все становится на свои места я опять могу входить на сайт и так до бесконечности

просто без ошибок меня не пускает на форум)) если я чего-то не замечаю под-толкните на правильный путь!)

Share this post


Link to post
Обратите внимание

По указанному вами в профиле "Board url" находится не IP.Board, либо модифицированный пиратский скрипт с удаленными копирайтами. Если вы указали неверный URL, пожауйста, поправьте его, потому что он скорее всего потребуется при диагностике вашей проблемы. Нелицензионные скрипты не приветствуются, т.к. зачастую именно некорректное "нуление" и является причиной проблем в них.

Share this post


Link to post

В админцентр можете войти? Проверьте домен cookie-ов в настройках, и попробуйте его прописать если нету (читайте внимательно описание настройки).

Share this post


Link to post

в админ центр могу спокойно зайти все хорошо,

я слегка не до понял вот это "Проверьте домен cookie-ов в настройках, и попробуйте его прописать если нету"

 

ээ даже не знаю что сказать у меня настроек Cookie вообще нету)

они пустые))

сейчас буду смотреть что получится

 

окей

 

вроде-бы все сделал ну префикс не указывал (не нуждаюсь)

но что вводить в поле "путь"?

Edited by Squipy

Share this post


Link to post

В админцентр можете войти? Проверьте домен cookies-ов в настройках

Ключевые слова подчеркнул.

Заходите в админцентр, идите в настройках cookies-ов (в правом верхним углу есть поиск по админцентру). Смотрите настройку "Домен" какой домен прописан, если его нету пытаетесь его прописать внимательно прочитав описание этой настройки. Если с перового раз не до поняли читайте еще несколько раз.

Share this post


Link to post

но что вводить в поле "путь"?

Остальное ничего не трогайте.

Share this post


Link to post

вроде-бы все сделал

Кукиcы у вас по прежнему не работают. Есть подозрения что в процессе "её решил но...", либо что-то поломали, либо выводятся данные до отправки кукисов.

 

Ну так и есть, первые байты страницы - ef bb bf

У вас какой-то файл в кодировке utf-8 с BOM. Найдите какой файл редактировали и пере сохраните или в windows-1251 или в utf-8 без BOM.

Share this post


Link to post

все сделал но ничего не поменяло

Share this post


Link to post

а я уже и не помню какой именно файл я изменял я их много трогал

 

и как на меня не в этом проблема проблема, я файлы начал изменять из-за этой ошибки

Edited by Squipy

Share this post


Link to post

В чем проблема вам указали, а в следствие чего она появилась остается только предполагать. Само по себе кодировка не меняется, только если вы пересохраняли файлы, т.е. редактировали (или смотря как переносили).

 

Если есть ssh можно поискать командой

 

find . -name '*.php' | xargs grep -lP '^\xEF\xBB\xBF'

. - нужно переместится в корень форума

 

либо перезалить форум и редактировать файлы в нормальной кодировке.

Share this post


Link to post

Писал ещё и в тех.поддержку хостинга вот что мне выдали

 

Nov 13 23:53:22 namea apache_error: [Wed Nov 13 23:53:22 2013] [error] [client 55.55.555.555] PHP Warning: Cannot modify header information - headers already sent by (output started at /sources/base/core.php:1) in public_html/ips_kernel/classAjax.php on line 305, referer: http://flawor.tmweb.ru/index.php?app=core&module=global&section=login
Edited by Squipy

Share this post


Link to post

Warning: Cannot modify header information - headers already sent by

То, собственно о чем и говорилось выше. Эти байт метки выводятся до отправки заголовках с кукисами браузеру.

Как минимум проверьте кодировку файла /admin/sources/base/core.php

Share this post


Link to post

хэх забавно..

вот прикол маленький файлы я проверял и они были в кодировке ютф бум и в итоге я их сменил на ютф после у мен полетел сайт вернул в ютф бум и все заработало как раньше проверил файл коре он был в ютф и я просто только что случайно поставил в ютф бум и вуаля все заработало)) о боги))

Share this post


Link to post

Там утф без бум бом, потому что меток уже нету.

 

ПС

ТС, не пренебрегайте знаками препинания, а то даже не понятно кто у вас маленький - прикол или файл

Share this post


Link to post

буду пытаться,

пере-залил бд,

тоже самое со входом( делал все как и раньше вроде бы)

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...