Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
wcp

Тормоза при создании новых тем

Recommended Posts

Включил отладку ошибок, увеличил время выполнения с 30 до 60 секунд - все равно при создании тем вываливаюсь в белую страницу, но тема тем не менее создается.

 

Fatal error: Maximum execution time of 60 seconds exceeded in /wind-travels.com/admin/sources/base/ipsRegistry.php

Fatal error: Maximum execution time of 60 seconds exceeded in /wind-travels.com/admin/sources/classes/parser.php

 

пинг-сервисы отключены, никого не уведомляю при создании топиков

 

помню, что беда эта началась давно, даже когда под задницей, пардон, был жирный сервак с безлимитными ресурсами.

кто-то посоветовал изменить группу "пользователи" на "пользователи2" (не суть дела в названии".

на какое время попустило, потом опять начались тормоза.

польлзователей всего около 3000, это не так много для форума

Share this post


Link to post
Share on other sites

А строчки где падает форум в ошибках не указываются?

Что-то я такого файла parser.php по адресу /admin/sources/classes/ не вижу. parser.php есть, но он в /admin/sources/classes/text/

Share this post


Link to post
Share on other sites

Сложилось впечатление, что дистрибутив палёный.

  • Upvote 1

Share this post


Link to post
Share on other sites

да-да, сорри, я запарился и скопировал предыдущий путь, конечно парсер в text лежит

 

у ipsregistry это строка 939

IPSDebug::setMemoryDebugFlag( "Registry initialized" );

 

у парсера 1354

$txt = preg_replace( '#(\s)?<img([^>]+?)src=(?:[\'"])' . preg_quote( $this->settings['public_cdn_url'] . 'style_emoticons/' . $this->registry->output->skin['set_emo_dir'] . '/' . $row['image'], '#' ) . '(?:[\'"])(?:[^>]+?)?>#', ' ' . $row['typed'], $txt );

Share this post


Link to post
Share on other sites

А при отправке сообщений проблем нету?

Без дебаггинга что можно посоветовать это проверить подписки и пинг сервисы (эти часто дохлые, а на некоторых хостингах не работает таймаут на запрос). Если есть доступ к серверу, установить xdebug и сделать дебаггинг. Ну или метками echo 'point 1'; exit; провести дебаггинг по цепочке файлов которые отрабатывают при создание темы.

Ввиду новых обстоятельств следует для начала почистить форум от вирусов.

Share this post


Link to post
Share on other sites

почистился

 

заметил, что нет проблем в разделе "триумвират", куда имеют доступ только рут админы

 

ps а есть еще раздел, куда имеют доступ только рут и модеры - там тоже нормально создаются.

 

проблема существует в общедоступных форумах, где тусуется группа "пользователи"

Share this post


Link to post
Share on other sites

еще наблюдение - что-то не так с основной группой "пользователи"

я уже писал, что как-то создал группу "пользователи2" и перенес в нее всех зареганых на тот момент

 

сейчас смотрю, что в "пользователи" опять попадали новые регистрации, почти 500 штук

я их перекинул в "пользователи2" и попробовал создать тему в общедоступном топике, довольно тяжелую тему - с большим текстом и десятком толстых вложений: СОЗДАЛАСЬ зараза!

 

и что это может быть интересно :(

 

ps сделал "пользователи2" дефолтной, но интерес к глюку не пропал

Share this post


Link to post
Share on other sites

Настройки -> Профили пользователей -> Подписки на темы и форумы

Share this post


Link to post
Share on other sites

да есть такое, владелец просил принудительную подписку для всех на новые темы, поэтому вся группа "пользователи" была подписала автоматом. А "пользователи2" я этой возможности лишил ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...