Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...

Recommended Posts

Здравствуйте, вдруг сегодня меня посетила ошибка 404

/forum/52-dropovodstvo/

Причем главная страница открывается без каких либо проблем. Вспомнив какие действия делал в АЦ сделал вывод, что неправильно отредактировал файл globalTemplate , тк редактировал его своими кривыми руками, без знания HTML, дабы удалить в нем кнопки соц сетей (готовый шаблон). После этого вроде бы все работало....Вобщем ошибка незаметно вылезла. Вся центральная страничка работает, но любой переход по ссылкам приводит к данной ошибке.

"Not Found

 

The requested URL /user/1-papa/ was not found on this server.

 

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

Share this post


Link to post
Share on other sites

Редактирования шаблонов к ссылкам не имеет никакого отношения. Тип чпу ссылок настраивается в Настройках -> Поисковая оптимизация (SEO). В конкретном случае скорее всего не хватает правила реврайта для htaccess. Не внимательно прочитали описания когда включали настройку "Использовать .htaccess mod_rewrite"?

Share this post


Link to post
Share on other sites

Спасибо огромное) Я нуб, на самом деле включил и забыл, вот вопрос, зачем лезть, если не знаешь))))

Share this post


Link to post
Share on other sites

В конкретном случае скорее всего не хватает правила реврайта для htaccess. Не внимательно прочитали описания когда включали настройку "Использовать .htaccess mod_rewrite"?

 

У меня сегодня на ipb 3.2 произошла такая ошибка, какие действия делал не могу вспомнить но делал все в разделе Безопасности. В шаблоны не лез.

первая страница форума открывается нормально, далее при нажатии на любую тему вылетает Error 404! File not found!

 

попробовал выключить настройку "Использовать .htaccess mod_rewrite"

выдает ошибку "На этой странице обнаружена циклическая переадресация"

 

что делать ума не приложу(

Share this post


Link to post
Share on other sites

Для начала отключить "использовать мод_реврайт" в настройках сео оптимизации, и удалить htaccess из корня форума, дабы исключить срабатывания левых реврайтов.

Если проблема не исчезнет, посмотреть адрес в адресной строке, возможно не правильно прописали адрес форума.

Если вышеописанные действия не помогут, тогда нужно привести адрес форума (который желательно было указывать в профиле).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...