Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Атаман

ipb 3.4.7 javascript

Recommended Posts

Обновил форум до 3.4.7, все без ошибок, но появились странности после обновления. Перестал работать JS (всплывающие окна и тд).

Решил это с помощью Сжать javascript и CSS? - Выкл Но это не выход. Дистрибутив перезаливал и тд.

Сегодня заметил, что в IE и в мобильных устройствах: нельзя перейти в список форумов только в начало темы

 

Безымянный.png

 

Версия PHP 5.4.35 (apache2handler) ( PHP INFO )

Отключенные PHP функции Нет данных

Загруженные дополнения Core, PDO, Phar, Reflection, SPL, SimpleXML, apache2handler, bz2, calendar, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imap, ionCube Loader, json, libxml, mbstring, mhash, mysql, mysqli, openssl, pcre, pdo_mysql, pdo_sqlite, session, shmop, sockets, sqlite3, standard, tokenizer, wddx, xml, xmlreader, xmlwriter, xsl, zip, zlib

Share this post


Link to post
Share on other sites

Странно. перезагрузил повторно папку (public и Admin/js) и всплывающие заработали, а вот с шаблоном, та-же проблема. Подскажите, что может быть?.

Share this post


Link to post
Share on other sites

При проблемах с javascript, в первую очередь нужно смотреть ошибки в консоли ошибок браузера.

В опере: Инструмент -> Дополнительно -> Консоль ошибок (CTRL + SHIFT + O)

Share this post


Link to post
Share on other sites

Это только в мобильном браузере так. Всплывающие окна работаю, консоль ошибок ничего не говорит, ельзя перейти в список форумов только в начало темы

Share this post


Link to post
Share on other sites

Что-это может быть?Консоль ошибок ничего не показывает. Такое только в IE - Хром

Share this post


Link to post
Share on other sites
Что-это может быть?Консоль ошибок ничего не показывает. Такое только в IE - Хром
Что именно? Что за переходы?

Share this post


Link to post
Share on other sites

Что именно? Что за переходы?

 

Когда используешь мобильную версию, с телефона или с пк В IE - Google хром не работает переход в раздел.

 

Читаешь тему, и при нажатии кнопки вернуть в предыдущий раздел ничего не происходит, просто оказываешься в начале темы, которую читал. Скриншот в первом посте.

 

http://ipbskins.ru/f...dpost__p__88899

Share this post


Link to post
Share on other sites

Зашел с ПК на форум <!--удалено--> (он же на скриншоте?), используя IE. Перешел в тему. Нажал на кнопку возврата. Работает, как и должно.

Share this post


Link to post
Share on other sites

Так там в коде ссылка на тему указана. Начните с проверки шаблона, отвечающего за переходы.

Share this post


Link to post
Share on other sites

globalTemplate? В нем то, что нужно.

Share this post


Link to post
Share on other sites

В шаблоне topicViewTemplate есть

<if test="$this->settings['_mobile_back_nav'] = 1"></if>

В самом начале.

Share this post


Link to post
Share on other sites

В шаблоне topicViewTemplate есть

<if test="$this->settings['_mobile_back_nav'] = 1"></if>

В самом начале.

 

 

Да есть

Share this post


Link to post
Share on other sites

globalTemplate? В нем то, что нужно.

Весь код globalTemplate

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...