Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
ralf

Ошибка при обновлении php до 5.4

Recommended Posts

Форум 3.4.3

Блоги 2.5.1

 

После обновления php с 5.3 до 5.4 появилась ошибка на главной странице блогов

Warning: Illegal string offset 'eopt_mode' in /var/www/admin/www/сайт/admin/applications_addon/ips/blog/sources/parsing.php on line 329

 

329 строка:

 

if ( $blog['blog_settings']['eopt_mode'] == "autohide" &&
	     ($entry['edit_button'] or $entry['del_button'] or $entry['send_trackback'] or $entry['lock'] or $entry['publish']) )

Как исправить?

Share this post


Link to post
Share on other sites

Обновить форум до 3.4.7.

3.4.3 бетка в которой очень много недостатков.

Share this post


Link to post
Share on other sites

Лицензия, к сожалению, закончилась на 3.4.3. Лицензия была от ibresource сейчас её не продлить.

Share this post


Link to post
Share on other sites

Лицензией торговали до 3.3.4, с 3.4.х торгуют только русификацией.

Share this post


Link to post
Share on other sites

Вот поэтому и спрашиваю как исправить эту ошибку.

Ошибка только в блогах, форум работает нормально.

Share this post


Link to post
Share on other sites

Подобные ошибки постят на форуме с постоянной периодичностью.

 

$blog['blog_settings']['eopt_mode'] == "autohide"

заменить на

isset($blog['blog_settings']['eopt_mode']) AND $blog['blog_settings']['eopt_mode'] == "autohide"

  • Upvote 2

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...