Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
m35

Проблемы после обновления до 3.4.8

Recommended Posts

Добрый день.

На сервере установлен nginx в качестве фронтэнда и apache2 в качестве бэкэнда ... не то чтобы у меня какая-то большая нагрузка, но мне было интересно и я настроил. Год всё работало хорошо.

Есть две проблемы после обновления с 3.4.6 до 3.4.8:

— При отправке темы или сообщения Страница с формой зависает, после чего nginx выдает "504 Gateway time-out", при этом данные в базу записываются ... тема создается, сообщение отправляется. Пробовал увеличить таймауты — не помогает.

— Форум перестал отправлять письма через SMTP (Google), "не удается соединиться с сервером".

 

Вопрос: это только у меня так, либо проблема версии 3.4.8 ?

Что можно предпринять?

Можно ли откатиться на 3.4.6, что для этого сделать и где взять дистрибутив?

Share this post


Link to post
Share on other sites
Можно ли откатиться на 3.4.6, что для этого сделать и где взять дистрибутив?

Поднять бэкап.

Share this post


Link to post
Share on other sites

Про почту, возможно и с гуглом так -

 

Попробуйте наладить отправку, возможно и попустит сервер.

Share this post


Link to post
Share on other sites

— При отправке темы или сообщения Страница с формой зависает, после чего nginx выдает "504 Gateway time-out", при этом данные в базу записываются ... тема создается, сообщение отправляется. Пробовал увеличить таймауты — не помогает.

Что в логах?

— Форум перестал отправлять письма через SMTP (Google), "не удается соединиться с сервером".

http://forums.ibresource.ru/topic/66169-pochta-po-smtp-s-shifrovaniem-tls-v-348/

Share this post


Link to post
Share on other sites
Поднять бэкап.

 

Проблема обнаружилась не сразу, понаписали уже, терять не хочется. И потом, интересно разобраться.

 

 

Спасибо, у меня изначально так tls://smtp.gmail.com а вот с портом да... заменил на 25 заработало.

 

Что в логах?

 

Типа такого...

 

Apache:

[Wed Jun 17 16:44:32 2015] [error] [client 78.25.121.126] Script timed out before returning headers: index.php, referer: http://ecuforum.ru/index.php?app=forums&module=post&section=post&do=new_post&f=22

 

Nginx:

2015/06/17 16:29:15 [error] 22624#0: *42821 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 78.25.121.126, server: ecuforum.ru, request: "POST /index.php? HTTP/1.1", upstream: "http://127.0.0.1:8080/index.php", host: "ecuforum.ru", referrer: "http://ecuforum.ru/index.php?app=forums&module=post&section=post&do=new_post&f=22"

Edited by m35

Share this post


Link to post
Share on other sites

System Settings > System > Email Set-up > В первой строке попробуйте PHP's mail()

Share this post


Link to post
Share on other sites

Однако, две проблемы одним зайцем, оказывается тормоза были только там где работает функция уведомления по e-mail, после замены порта на 25 в настройках — обе проблемы решились.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...