Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Hardwell

SQL ошибка при входе в аккаунт

Recommended Posts

Всем доброго времени суток! Стоит форум ipb 3.4.6, решил установить мост между ним и dle 10.2, установил, вроде все нормально работает, но когда я нажимаю кнопку "Войти" на форуме, то вылезает ошибка с Driver Error (кода ошибки там нет, просто пишет обратитесь к администратору), там на этой странице еще кнопка вернуться назад. Окей, возвращаюсь обратно и каким-то магическим образом я уже авторизирован и могу пользоваться форумом, но все-же неприятно видеть эту ошибку и причем каждый раз при входе. В логах sql ошибок нашел следующее

 

Error: 1115 - Unknown character set: 'UTF-8'
IP Address: 127.0.0.1 - /forum/index.php?app=core&module=global&section=login&do=process
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
mySQL query error: SET NAMES 'UTF-8'
.--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
| File                                                                       | Function                                                                      | Line No.          |
|----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
| admin/applications/forums/extensions/memberSync.php                        | [forumsMemberSync].db_connect                                                 | 147               |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/sources/base/core.php                                                | [].call_user_func_array                                                       | 2281              |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/sources/handlers/han_login.php                                       | [iPSLib].runMemberSync                                                        | 544               |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

 

Видимо тут что-то связано с кодировкой. Буду очень рад помощи, заранее спасибо за ответ!

Share this post


Link to post
Share on other sites

 Error: 1115 - Unknown character set: 'UTF-8'

Вы неправильно написали кодировку подключения к mysql серверу, UTF-8 пишется без слеша - UTF8.

 

Исправьте в /admin/applications/forums/extensions/dbconfig.php, константа COLLATE.

  • Upvote 1

Share this post


Link to post
Share on other sites

Ошибка исчезла, большое спасибо за помощь!)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...