Skip to content

Ошибка при запуске Queue

Приветствую, товарищи! Помогите разобраться с проблемой. Суть ее в том что не запускается задача quene. Стоит заблокированной. При разблокировке и ручном запуске, через cron - пишет ошибки EX1064:

SELECT * FROM `blog_comments` WHERE comment_id < IS NULL ORDER BY comment_id DESC LIMIT 0,50
IPS\Db\Exception: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'IS NULL ORDER BY comment_id DESC LIMIT 0,50' at line 1 (1064)
#0 /var/www/mighelruis/data/www/clubcanon.ru/system/Db/Select.php(346): IPS\_Db->preparedQuery('/*IteratorItera...', Array)
#1 /var/www/mighelruis/data/www/clubcanon.ru/system/Db/Select.php(408): IPS\Db\_Select->runQuery()
#2 [internal function]: IPS\Db\_Select->rewind()
#3 /var/www/mighelruis/data/www/clubcanon.ru/applications/core/extensions/core/Queue/RebuildPosts.php(98): IteratorIterator->rewind()
#4 /var/www/mighelruis/data/www/clubcanon.ru/system/Task/Task.php(48): IPS\core\extensions\core\Queue\_RebuildPosts->run(Array, 0)
#5 /var/www/mighelruis/data/www/clubcanon.ru/applications/core/tasks/queue.php(44): IPS\_Task::runQueue()
#6 [internal function]: IPS\core\tasks\_queue->IPS\core\tasks\{closure}()
#7 /var/www/mighelruis/data/www/clubcanon.ru/system/Task/Task.php(338): call_user_func(Object(Closure))
#8 /var/www/mighelruis/data/www/clubcanon.ru/applications/core/tasks/queue.php(56): IPS\_Task->runUntilTimeout(Object(Closure))
#9 /var/www/mighelruis/data/www/clubcanon.ru/system/Task/Task.php(245): IPS\core\tasks\_queue->execute()
#10 /var/www/mighelruis/data/www/clubcanon.ru/applications/core/modules/admin/settings/advanced.php(541): IPS\_Task->run()
#11 [internal function]: IPS\core\modules\admin\settings\_advanced->runTask()
#12 /var/www/mighelruis/data/www/clubcanon.ru/system/Dispatcher/Controller.php(85): call_user_func(Array)
#13 /var/www/mighelruis/data/www/clubcanon.ru/applications/core/modules/admin/settings/advanced.php(35): IPS\Dispatcher\_Controller->execute()
#14 /var/www/mighelruis/data/www/clubcanon.ru/system/Dispatcher/Dispatcher.php(129): IPS\core\modules\admin\settings\_advanced->execute()
#15 /var/www/mighelruis/data/www/clubcanon.ru/admin/index.php(13): IPS\_Dispatcher->run()
#16 {main}

При включении "Запускать автоматически при посещении (по умолчанию)" задача просто блокируется.

Ошибки одинаковые, но к разным таблицам (задачам): blog_comments, gallery_comments, и др.

 

Если запустить все задачи вручную, то появляется ошибка:

1S111/1 You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'IS NULL ORDER BY archive_id DESC LIMIT 0,50' at line 1

 

В чем, собсно, дело? Сайт обновлял уже несколько раз. Сейчас последняя версия. Проблема не уходит :( .

Featured Replies

В чем, собсно, дело? Сайт обновлял уже несколько раз. Сейчас последняя версия. Проблема не уходит

В запросе есть синтаксическая ошибка поэтому задача блокируется.

 

Попробуйте в applications\core\extensions\core\Queue\RebuildPosts.php

Найти

' < ?', $data['runPid']

Заменить на

' < ?', (int) $data['runPid']

  • 1 month later...

Спасибо! Только увидел ответ. Фоновые процессы пошли.

Сыровата четверка еще. После включения архивации появилась новая ошибка:

 

SELECT COUNT(*) FROM `forums_topics` WHERE topic_archive_status!=3 AND last_post1451930932 AND forum_id IN(33,34,39,40) AND pinned='0' AND featured='0' AND approved='1' AND !(posts>'1') AND !(views>'1')
IPS\Db\Exception: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near '? AND forum_id IN(33,34,39,40) AND pinned=? AND featured=? AND approved=? AND !(' at line 1 (1064)
#0 /var/www/mighelruis/data/www/.../system/Db/Select.php(346): IPS\_Db->preparedQuery('/*IPS\\forums\\mo...', Array)
#1 /var/www/mighelruis/data/www/.../system/Db/Select.php(408): IPS\Db\_Select->runQuery()
#2 /var/www/mighelruis/data/www/.../system/Db/Select.php(329): IPS\Db\_Select->rewind()
#3 /var/www/mighelruis/data/www/.../applications/forums/modules/admin/forums/settings.php(74): IPS\Db\_Select->first()
#4 [internal function]: IPS\forums\modules\admin\forums\_settings->manageArchiving()
#5 /var/www/mighelruis/data/www/.../applications/forums/modules/admin/forums/settings.php(47): call_user_func(Array)
#6 /var/www/mighelruis/data/www/.../system/Dispatcher/Controller.php(96): IPS\forums\modules\admin\forums\_settings->manage()
#7 /var/www/mighelruis/data/www/.../system/Dispatcher/Dispatcher.php(129): IPS\Dispatcher\_Controller->execute()
#8 /var/www/mighelruis/data/www/.../admin/index.php(13): IPS\_Dispatcher->run()
#9 {main}

Покажите результат запроса

 

SELECT archive_app, archive_value, archive_text, archive_unit, archive_skip FROM forums_archive_rules WHERE archive_field = 'lastpost'

 

Еще раз настройте фильтры архивации, а конкретно тип Last Post.

@siv1987, ответ таков: Данное выделение не содержит уникального столбца. Изменение сетки, выставление галочки, редактирование, копирование и удаление невозможно.

 

Изменить настройки архиваци нет возможности. При попытке открыть вкладку архивации появляется вышеуказанная ошибка.

Ну и корявый перевод. Ошибки лучше приводить на оригинальном языке.

Ответ таким и был. Я не переводил.

Перевод форума. Языковой перевод.

Create an account or sign in to comment

Account

Navigation

Search

Search

Configure browser push notifications

Chrome (Android)
  1. Tap the lock icon next to the address bar.
  2. Tap Permissions → Notifications.
  3. Adjust your preference.
Chrome (Desktop)
  1. Click the padlock icon in the address bar.
  2. Select Site settings.
  3. Find Notifications and adjust your preference.