Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
cyrax_02

IP.Board 3.4.x и php 5.5: патч для classEmail.php

Recommended Posts

Как известно, IP.Board до версии 3.4.7 не отправляет почту на новых версиях php (5.5+). И на этот случай имеется некий патч, который, судя по всему, представляет из себя classEmail.php из последних версий 3-й линейки (3.4.8, 3.4.9).

 

Кто-нибудь поделится этим самым патчем ?

На форумах ссылки дают на официальный сайт IPS. Но ссылки нерабочие. На сайте их найти не могу. На этом форуме соответствующих закреплённых тем нет, патч непосредственно вроде как нигде не выложен (на этом форуме).

 

Этот "патч" упоминается вот здесь и вот здесь.

Share this post


Link to post
Share on other sites

Не отправляется почта на php 5.5?.. Не слышал об этом. Знаю о проблеме с смтп по протоколу ssl. Решение есть на нашем форуме. В любом случае IPS больше не поддерживает версию 3.x, даже раздел в маркетплейсе был убран. Как вариант возьмите файл из последней версии форума, в нем содержаться все патчи. А лучше обновится.

Share this post


Link to post
Share on other sites

Любят разработчики в CMS-ках блокировать вывод ошибок через @ (include, mail и пр.). Из-за этого приходится гадать, почему не работает тот или иной функционал движка. Из-за этого на форумах плодится миллион одинаковых тем в поисках телепатов...

 

if( $this->mail_method != 'smtp' )
{
/* Fifth parameter not supported in safe mode 
@link http://community.invisionpower.com/tracker/issue-30145-php-mail-and-safe-mode */
if( ( defined('SAFE_MODE_ON') AND SAFE_MODE_ON ) OR $this->settings['safe_mode_skins'] )
{
	if ( ! @mail( $this->to, $this->subject, $this->message, $this->rfc_headers ) )
	{
		$this->_fatalError( "Could not send the email", "Failed at 'mail' command (SAFE MODE)" );
	}
}
else if ( ! @mail( $this->to, $this->subject, $this->message, $this->rfc_headers, $this->extra_opts ) )
{
	if ( ! @mail( $this->to, $this->subject, $this->message, $this->rfc_headers ) )
	{
		$this->_fatalError( "Невозможно отправить сообщение", "Ошибка функции 'mail'" );
	}
}
}

PHP Warning: mail(): Multiple or malformed newlines found in additional_header in /.../forum/ips_kernel/classEmail.php on line 706

 

http://stackoverflow.com/a/30897935

A security risk in PHP mail() function has been fixed and extra newlines in additional_headers are allowed no more. Because extra newlines mean: now starts the email message (and we surely don't want somebody to inject some newlines through headers followed by an evil message).

 

What previously have worked fine, e.g. just having extra newlines after headers or even passing the whole message to additional_headers, will function no more.

 

Solution:

 

Sanitize your headers. No multiple newlines in additional_headers argument. These count as "multiple or malformed newlines": \r\r, \r\0, \r\n\r\n, \n\n, \n\0.

Use additional_headers for headers only. Email message (multipart or not, with ir without attachments, etc) belongs in message argument, not in headers.

Share this post


Link to post
Share on other sites
Знаю о проблеме с смтп по протоколу ssl. Решение есть на нашем форуме.

Вот оно. Если кому понадобится. Но в данном случае работа идёт через php-функцию mail() и проблема заключется в некорректном (нестрогом) формировании заголовков письма движком IP.Board версий до 3.4.7.

 

В любом случае IPS больше не поддерживает версию 3.x, даже раздел в маркетплейсе был убран

Тем не менее, все патчи оставили. Но сабжевый - удалили...

 

Как вариант возьмите файл из последней версии форума, в нем содержатся все патчи.

Последняя - это 3.4.9. Нет её у меня. Мне бы только класс classEmail.php - может, кто поделится ?

А вообще, раз на форумах идёт речь о патче (да ещё ссылка даётся на официальный форум IPS), значит, сабжевый патч существует. Пусть и удалили его с официального сайта, но но на других ресурсах должен ведь быть...

Share this post


Link to post
Share on other sites

А вот и патч для IP.Board 3.4.x с официального сайта IPS, который содержит обновлённый classEmail.php (корректно формирующий заголовки письма в новых версиях php). По размеру чуть отличается от того же файла из IP.Board 3.4.9.

classEmail.php

  • Upvote 1

Share this post


Link to post
Share on other sites

Отличается только двумя строками в комментариях заголовка vVERSION_NUMBER и Last Updated, в остальном они идентичны.

Share this post


Link to post
Share on other sites
А лучше обновится.

Так ведь нельзя же обновляться с неактивным лицензионным ключом.

А после продления лицензии уже на 4-ку будет переходить...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...