Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Атаман

Нет иконок после обновления 3.4.9 - 4.1.17.1

Recommended Posts

Обновил 3ку до 4 актуальной версии, без проблем...Логи пусты.

Но! обратил внимание, что у ресурсов внешнего вида не хватает иконок (графических элементов дизайна) права 777 выставлены. Вот думаю, как оно так получилось.

 

Путь потерянной одной из иконок /uploads/set_resources_7/d0e70b4cbb9ab8afb1bc1065a3f8487a_wizard_step_large.png ее там нет, а на тестовом форуме они присутствуют.

 

на фтп присутствуют тоже /forum/admin/upgrade/img и в /forum/admin/install/img (но папку install после обновы я удаляю всегда)

 

Была одна ситуация после обновления этого форума, и на других ресурсах такое замечал.

- После обновления форума все на вид отлично, и через некоторое время, как-бы слетает дизайн АЦ и публичной части, получается белый фон и текст. Выход прост, очистить кэш и все становится отлично и иконки на месте.

 

Можно как-то сбросить настройки внешнего вида, чтоб их вернуть, чтоб не грузить со стороны? Понимаю, что вопрос глуп.. но все же.

Share this post


Link to post
Share on other sites

Есть такой баг при установке. На IPS подтверждают но воспроизвести не могут, с чем связан неизвестно. При установке появляется ошибка, что не хватает прав на записи, хотя все права есть. У меня такое случалось на локалхосте (ОС Win, php 5.4). Решение только одно - сброс кеша после установки.

Share this post


Link to post
Share on other sites

Да перед обновой мне красным высветилось предупреждения, выставите права 777 на определенные каталоги я это сделал и обновил. Но мелочь с иконками непонятная. После перестроения кэша они не вернулись, вот думаю удалить папку set_resources_1 чтоб она пересоздалась, но не факт что создастся.

 

Версия PHP 5.6.29-1~dotdeb+7.1

Версия MySQL 5.5.53-0+deb7u1

Share this post


Link to post
Share on other sites

На фтп переименовал set_resources_1 и css_built_1, запустил удаления кэша. css_built_1 создалась навая, а папка с иконками set_resources_1 нет, вернул имя обратно.

 

Но логику я так и не понял. Решил ради эксперимента загрузить в ресурсы темы свою иконку (новую) загрузилось все красиво, но после этого))))) пропавшие иконки появились.... Где тут Логика??? :blink:

Edited by Атаман

Share this post


Link to post
Share on other sites

По моему папки удалять нельзя, нужно только очистить. Точно не помню, знаю что тоже игрался с этими папками.

  • Upvote 1

Share this post


Link to post
Share on other sites

Думаю удаление к плохому не приведет, буду знать на будущее что нужно очистить... Я их просто переименовал и обратно подкинул папку с иконками, а css пересоздалась с тем-же именем.

Спасибо, странное решение проблемы)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...