Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
9IPOCTb

https

Recommended Posts

Приветствую уважаемые форумчане. Подключил https к форуму и после каждого обновления страницы слетают иконки, выглядят как квадратики. Подскажите как исправить?

форум 4.2

Share this post


Link to post
Share on other sites

очистка кеша форума помогает, но после обновления страницы иконки опять слетают

Share this post


Link to post
Share on other sites

Не могу попасть к Вам на форум. Может кэш браузера?

  • Upvote 1

Share this post


Link to post
Share on other sites

кеш браузера не причем к сожалению, такая проблема и в безопасном режиме и в других браузерах

Share this post


Link to post
Share on other sites

config_global http на htpps переделали ? + бывает такое, что в constant.php тоже корректировки нужно внести

  • Upvote 1

Share this post


Link to post
Share on other sites

в config_global да, менял, стоит вот так:

$INFO['board_url'] 			= 	'https://'.$_SERVER['HTTP_HOST'];

а файла constant.php вообще нет, он должен быть?

Share this post


Link to post
Share on other sites
а файла constant.php вообще нет, он должен быть?

Разные настройки кэширования и тд. Значит Вы не используете.

  • Upvote 1

Share this post


Link to post
Share on other sites

значит нужно добавить этот файл? а какое содержание должно быть?

либо я что-то не так понял?(

Share this post


Link to post
Share on other sites

проблему с иконками решил спасибо Атаману за наводку, прописав линк на фонтавесоме со стороннего сервиса, осталась проблема с боковым блоком на зеркалах форума, только на зеркалах, на основном домене все норм, и только в боковых блоках, возможно очередной скрипт не подгружается, подскажите какой скрипт отвечает за это, либо есть другое решение данной проблемы?

скрин ошибки:

post-59488-0-55448900-1538487514_thumb.png

заранее спасибо всем за ответы

Edited by 9IPOCTb

Share this post


Link to post
Share on other sites

ошибки в консоли:

Failed to load resource: net::ERR_BLOCKED_BY_CLIENT
(index):1 Access to Font at 'https://сайт1/applications/core/interface/font/icomoon.woff?v=-29n77j' from origin 'https://сайт2' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://сайт2' is therefore not allowed access.
(index):1 Access to Font at 'https://сайт1/applications/core/interface/font/icomoon.ttf?v=-29n77j' from origin 'https://сайт2' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://сайт2' is therefore not allowed access.
(index):1 Failed to load https://сайт1/index.php?/profile/20869-lower227/&do=hovercard&csrfKey=b44402280d74bef94fde92a1168cb84d: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://сайт2' is therefore not allowed access.

Share this post


Link to post
Share on other sites

заработало) вроде...

настроил CORS и поехало, пока буду тестировать, если возникнут проблемы отпишусь

спасибо вам! заставляете задумываться пока пишешь пост и начинаешь искать решение в другом направлении :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...