Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Som

Универсальный установщик мдов

Recommended Posts

Есть инструкция, но чего то я в ней не догоняю.

 

Вы должны выполнить эти действия для установки и использования скрипта

Загрузка - Загрузите папки /mod_install и /sources в корневые папки с вашими форумами. Файл index.html в папку /mod_install, а файл umi.php в папку /sources/components_acp.

Удалить - Проверьте и посмотрите, если у вас есть файл с именем index.php, или папку /images вашего форума. Проверьте, есть ли у вас уже существующий папки от старой верии этой модификации. Если таковые есть, то смело удаляйте старые версии.

CHMOD - Выставьте права доступа на папку /mod_install - 755. На остальные файлы - 644.

Установка - Войдите в Админцентр, и на вкладке ПРОЧЕЕ кликните Компоненты -> ссылка Управление компонентами. Затем сделайте 'Импорт компонента через XML файл'. Импортируйте файл ipd_components.xml который находится в нашей папке.

Установка ваших модов! - После установки нашего скрипта на форум на вкладке КОМПОНЕНТЫ появится новая вкладка. Теперь, для использования установщика, вы должны воспользоваться нашим уомпонентом установки модов.

 

Удалить index.php откуда? С корневого каталога что ли? ;)

 

На вкладке Компоненты я его не вижу

Share this post


Link to post
Share on other sites

Позвольте поинтересоваться. кто переводил инструкцию?

Посадить бы его за учебник английского.

2. Delete - Check and see if you have a file named index.php, or a folder called /images in your forum's /mod_install directory. These could be left over from previous versions of this script. If either of these exist on your site, delete them. In addition, any XML and PHP files in this /mod_install directory from a previous IPB version can be safely deleted as well.

Share this post


Link to post
Share on other sites

А можна преревод, я перевел и получил то же самое

Share this post


Link to post
Share on other sites

Короче, нужно проверить наличие файла index.php, или папки /images в папке /mod_install

Такие могут остаться от предыдущих версий Установщика. Если раньше не ставили его - значит ничего удалять не надо.

Share this post


Link to post
Share on other sites
Короче, нужно проверить наличие файла index.php, или папки /images в папке /mod_install

Такие могут остаться от предыдущих версий Установщика. Если раньше не ставили его - значит ничего удалять не надо.

Усе сделал, но на вкладке Компоненты не появилось не чего нового.

Share this post


Link to post
Share on other sites

интересный вопрос. А вы компонент импортировали? :lol:

Share this post


Link to post
Share on other sites
интересный вопрос. А вы компонент импортировали? :lol:

Да все сделал по выше указанной инструкции

 

так же есть папка documentation с файлами mods.xml, sample.php, sample.xml

Про них не че не сказано, я и не трогал

Edited by Som

Share this post


Link to post
Share on other sites

Не могу понять, что я делаю не так...

 

Скачал мод, который устанавливается с помощью универсального установщика модов. Закинул сам мод, начал инсталяцию. Идет добавление полей, создаются настройки, группы, фрагменты, обновляется кеш, все ок, даже сообщения есть:

 

Установка модификации завершена...

 

но в поле Установлен? красный крест не установлен. Может еще CHMOD нужно что-то спецом править под этот установщик или еще что-то делать? Устанавливаю первый раз!

Спасибо :)

Share this post


Link to post
Share on other sites

А с другими модификациями как?

Share this post


Link to post
Share on other sites
А с другими модификациями как?

 

В том то и дело, что тоже не работает... Я сначала тоже подумал, что мод глюкавый, попробовал на другом - ситуация аналогична, установка идет, но заканчивается все красным крестом...

Share this post


Link to post
Share on other sites

Попробуйте установить другую версию UMI.

Share this post


Link to post
Share on other sites

Ну а компоненты-то работают? А если на крест нажать?

Share this post


Link to post
Share on other sites

У меня вот какая беда теперь. Я скачала универсальный установщик модов как русский так и английский для своей версии форума. Все установила по инструкции, но во вкладке Компоненты он не появился. Я импортировала xml фаил с настройками, вообщем все в точности как сказано в инструкции. Пробовала устанавливать и русский и английский... не помогает. И версии разные ставила - тоже не помогло. Подскажите пожалуйста... Заранее благодарна.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...