Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Walk

После взлома сайта перестал работать форум

Recommended Posts

Форум IPB 2.1.7

Ошибка:

Parse error: syntax error, unexpected T_VARIABLE in /home/diabloru/public_html/forum/ips_kernel/class_db.php on line 1

 

Был украден доступ к фтп сайта, на странички добавлен iframe

 

пасс сменил, iframe убрал, а вот форум перестал работать.

 

В чем проблема и как исправить?

Share this post


Link to post
Share on other sites

ну был украден доступ к фтп.

Вы на 100% уверены, что ниодин из файлов форума не подвергнулся изменению?)

перезаливайте файлы, переустанавливайте моды :)

Share this post


Link to post
Share on other sites

Поставить форум по новой?

 

Можно. А как с темами, сообщениями, пользователями? или если подцепить туже базу данных то все востановится?

 

Где то можно об этом подробней почитать? Т.е. упал форум, как восстановить

Share this post


Link to post
Share on other sites

Темы/сообщения/пользователи сохранятся.

Вы не базу меняете, а всего лишь файлы форума перезаливаете.

Это нужно для того, чтобы заменить файлы, которые могли быть испорчены при взломе.

Но если ранее были установлены моды с изменением файлов, придется по новой изменять.

 

Но я бы обратилась к специалистам, дабы не поломать ничего.

Или делайте бэкап и по одному меняйте, чтобы найти "причинный".

Share this post


Link to post
Share on other sites
Но я бы обратилась к специалистам, дабы не поломать ничего.

а сколько такая услуга стоит у специалистов?

Share this post


Link to post
Share on other sites

Если все данные сохраняются в MySQL базе, то перезалить форум и поставить скин в общем то не долго... пойду сносить.

Share this post


Link to post
Share on other sites

Скин переставлять не придется...

Share this post


Link to post
Share on other sites

Снес форум, поставил новый, поставил на старой MySQL базе... а форум как новый... :)

 

что делать?

Share this post


Link to post
Share on other sites

Писать в Контакты программистам.

Share this post


Link to post
Share on other sites
Снес форум, поставил новый, поставил на старой MySQL базе... а форум как новый... :)

 

что делать?

Вам же говорили "перезалить файлы", а вы установку заново запустили? ССЗБ :) Бекап сделали хоть?

Share this post


Link to post
Share on other sites
Вам же говорили "перезалить файлы", а вы установку заново запустили? ССЗБ :) Бекап сделали хоть?

Мда... спасибо... человеку который с форумами на Вы, перезалить означает "удалить сратое и залить новое"

 

Т.к. было подозрение что "не все так просто" перед удалением выкачал все из папки форума.

 

Fisana

Буду писать...

Edited by Walk

Share this post


Link to post
Share on other sites

тьфу блин. Если вы форум переустановили и бекапа нет то даже мы не поможем.

А если есть, и вы с базой данных ничего не делали, тогда просто conf_global надо настроить на бд

Share this post


Link to post
Share on other sites

Связались с топикстартером, попробуем решить проблему. :)

 

В общем, догадки были верны — форум был удален при переустановке. Вирус я убрал, но это тут ничем не поможет.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...