Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Shmatko

Прикреплённые изображения в IP.Blog 2.0.4

Recommended Posts

У меня возникла проблема. Вроде всё настроил для работы IP.Blog 2.0.4 во время тестирования обнаружил, что прикреплённые изображения не загружаются. На каком то форуме я читал об этом, теперь не могу найти его, при переустановке фаерфокса удалились все закладки :D Проблема в чём. Изображение грузится, урезается и ложится в папку, которую указываешь в настройках. Урезанное изображение отображается, но когда кликаешь на нём для увеличения размера, появляется чёрный полупрозрачный квадрат и изображение пытается загрузится, но безрезультатно.

5.jpg

Share this post


Link to post
Share on other sites

Что-то с lightbox. Перезалейте скрипты для него...

Share this post


Link to post
Share on other sites
Что-то с lightbox. Перезалейте скрипты для него...

Для форума и галереи lightbox нормально всё открывает. В галереи это даже настраивается, есть возможность выбрать, каким образом будут открываться прикреплённые изображения. Fisana я не знаю какие файлы отвечают за lightbox. Вернее я не знаю, какие скрипты нужно перезаливать.

Share this post


Link to post
Share on other sites

public\js

Перезалейте те, где содержится корень "blog", например, ipb_blogentry.js

Share this post


Link to post
Share on other sites
public\js

Перезалейте те, где содержится корень "blog", например, ipb_blogentry.js

 

Ничего не помогает. Защёл я на форум производителя IP.Board у них в блоге вообще не используется lightbox у них изображение открывается просто на новой вкладке. Настроек в блоге нет, чтобы задавать каким образом будут открываться изображения. Может что в коде исправить.

Вот страница моих блогов, может и вправду у меня Винда глючит. http://skier.shmatko.biz/index.php?/blogs/

Кстати в одном из блогов интересна версия, почему будет конец света в 2012 году. Эту информацию я собрал из интернета, вывод - мой.

Share this post


Link to post
Share on other sites

Большое Вам спасибо, нет БОЛЬШУЩЕЕ ВАМ СПАСИБО!!!!

 

Ну а тем, кто не хочет переводить, или как Фисана говорит "Совсем необразованный" рассказываю, что нужно сделать чтобы решить эту проблему.

Надо из версии IP.Board 3.0.4 скопировать файл plugin_blogentry.php который лежит в папке admin/applications/core/sources/classes/attach

и вставить в тоже самую папку версии 3.0.5 и изображение начинают загружаться. :rolleyes:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...