Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
blue13

ошибка при работе с базой данных при установке

Recommended Posts

Здравстуйте :)

уже битый час мучаюсь с одной проблемой:

 

при установке IPBoard (после того, как я нажимаю "Начать установку"),

выходит ошибка

 

Возникла ошибка при работе с базой данных.

 

 

sql_error_log Говорит следующее:

 

===================================================
Гата: Wed, 17 Feb 2010 22:42:55 +0000
Номер ошибки: 1064
Ошибка: You have an error in your SQL syntax near 'NAMES 'utf8'' at line 1
IP Адрес: 127.0.0.1
Страница: 
Отладочная информация: array (
 1 => 
 array (
'file' => 'd:\\hst\\withart-ru_8462ec4a\\http\\forum\\ips_kernel\\classDbMysqliClient.php',
'line' => 122,
'function' => 'query',
'class' => 'db_driver_mysql',
 ),
 2 => 
 array (
'file' => 'd:\\hst\\withart-ru_8462ec4a\\http\\forum\\admin\\setup\\sources\\base\\ipsRegistry_setup.php',
'line' => 1239,
'function' => 'connect',
'class' => 'db_driver_mysql',
 ),
 5 => 
 array (
'file' => 'd:\\hst\\withart-ru_8462ec4a\\http\\forum\\admin\\setup\\applications\\install\\sections\\install.php',
'line' => 211,
'function' => '_setUpDBDriver',
'class' => 'install_install',
 ),
 6 => 
 array (
'file' => 'd:\\hst\\withart-ru_8462ec4a\\http\\forum\\admin\\setup\\applications\\install\\sections\\install.php',
'line' => 76,
'function' => 'install_sql',
'class' => 'install_install',
 ),
 7 => 
 array (
'file' => 'd:\\hst\\withart-ru_8462ec4a\\http\\forum\\admin\\setup\\sources\\base\\ipsController_setup.php',
'line' => 251,
'function' => 'doExecute',
'class' => 'install_install',
 ),
)
mySQL query error: SET NAMES 'utf8'

 

что-то не так с кодировкой? я пыталась менять, и всё без толку. :)

объясните, пожалуйста, если понимаете, в чем тут дело.

Share this post


Link to post
Share on other sites

Вообще насколько я знаю кодировка по умолчанию cp1251, уже после установки можно сконвертировать в utf-8.

 

Посмотрите кодировку по умолчанию для создаваемых таблиц - возможно проблема в этом.

Share this post


Link to post
Share on other sites

спасибо за ответ)

 

кодировка для таблиц БД - cp1251, а в conf_global.php прописан utf8, но я уже пробовала менять и так и так) бесполезною

 

 

ой. еще увидела на 3 шаге (где выбираешь приложения) сверху появляется:

 

Warning: opendir(d:/hst/withart-ru_8462ec4a/http/forum/admin/applications_addon/other) [function.opendir]: failed to open dir: Invalid argument in d:\hst\withart-ru_8462ec4a\http\forum\admin\setup\applications\install\sections\apps.php on line 90

 

Warning: readdir(): supplied argument is not a valid Directory resource in d:\hst\withart-ru_8462ec4a\http\forum\admin\setup\applications\install\sections\apps.php on line 92

 

Warning: closedir(): supplied argument is not a valid Directory resource in d:\hst\withart-ru_8462ec4a\http\forum\admin\setup\applications\install\sections\apps.php on line 125

Share this post


Link to post
Share on other sites

Так у вас 3-я версия????

 

А почему в разделе 2й пишете?))

Share this post


Link to post
Share on other sites
Так у вас 3-я версия????

 

А почему в разделе 2й пишете?))

 

 

пардон, перепутала)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...