Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Sannis

Консоль ошибок javascript

Recommended Posts

Часто на форуме возникают вопросы о неверной работе модификаций или функций форума, использующих AJAX, javascript, как то редактор или сворачивание категорий. Обычно ответ на подобные вопросы выглядит так:

 

Для ответа нужно зайти в:

Opera: Инструменты -> Дополнительно -> Консоль ошибок;

Firefox: Инструменты -> Консоль ошибок;

, очистить список ошибок и проделать действия, реакцию форума на которые вы считаете ошибочной. После чего написать на форум список возникших ошибок.

 

P.S. Если у вас IE, проверьте работу функций в других браузерах. Eсли не работает только в IE, то лучше дать адрес форума знающим людям. Продвинутые могут ознакомиться со статьями.

 

P.P.S. Как обнаружить ошибку ява-скрипта? .

Share this post


Link to post
Share on other sites

Вот - у меня как раз с этим проблема. Пытался вставить рекламу на сайт. И вот блок что после поста идет встает без проблем путем редактирования файла topicViewTemplate. А далее самое интересное - начинаю редактировать файл globalTemplate - и вот тут после редактирования появляется глюк - 3413183_3641193.PNG форма профиля становиться открытой, закрывая при этом поиск и не закрывается - при нажатии на нее открывается профиль. И далее если удалить все чего наменял в globalTemplate все равно это окно торчит и лечиться все это только полной заменой скина. Кто нибудь знает как это вылечить? (пробовал на стандартном скине и еще на одном)

Смотрел консоль ошибок - вообще ничего не понял. Может кто нибудь с подобным сталкивался?

Кстати кроме этого глюка так же не работают смайлы и визуальный редактор (RTE) ю

Share this post


Link to post
Share on other sites

Некорректно рекламу вставляли. Нарушили какой-то тег.

Share this post


Link to post
Share on other sites

Делаю все по инструкции с форума http://community.invisionpower.com/

Вот к примеру в globalTemplate вставляем код перед <div id='content' class='clear'> - код стандартный (Пробовал и Adbrite и Google) - и даже без тегов - код виден - но все клюки о которых я писал присутствуют. Что меня больше всего удивило - если удалить код и вернуть все обратно - глюки остаются!!!! И приходиться полностью сносить тему и затем инсталить ее заново.

 

Скорее бы 3.1 вышел - там вон какие вкусности обещают

http://community.invisionpower.com/blog/11...de-integration/

http://community.invisionpower.com/blog/11...gration-part-2/

Share this post


Link to post
Share on other sites
Делаю все по инструкции с форума

Можете дать прямую ссылку на инструкцию. Проверю на тестовом форуме.

 

Скорее бы 3.1 вышел - там вон какие вкусности обещают

Скорее всего в конце мая - в начале июня увидим.

Share this post


Link to post
Share on other sites
Можете дать прямую ссылку на инструкцию. Проверю на тестовом форуме.

 

 

Скорее всего в конце мая - в начале июня увидим.

 

http://community.invisionpower.com/resourc...html?record=352

http://community.invisionpower.com/resourc...html?record=208

 

Вот по этим инструкциям делал

Share this post


Link to post
Share on other sites
и лечиться все это только полной заменой скина.

Можно было обновить кеш-файлы, скорее всего помогло и без переустановки

 

Кстати кроме этого глюка так же не работают смайлы и визуальный редактор (RTE) ю

После установки или было раньше?

 

Вот по этим инструкциям делал

Если до вечера не решится, посмотрю.

 

Заодно вечером и тему разделю. А то мы говорим явно не о консоли.

Share this post


Link to post
Share on other sites
После установки или было раньше?

 

Нет - только после установки - так все прекрасно работает

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...