Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Scalpel

Проблема с меню

Recommended Posts

Такая проблема. Иногда при открытии сайта, верхнее меню (пользователи, календарь, чат) открывается не с первого раза. То есть приходится 3 раза кликать для открытия необходимого пункта. Особенно такое в IE6, но пару раз заметил и в других браузерах. Причем если посмотреть на ссылку которая ведет то она имеет такой вид

http://сайт.ру/index.php?app=members&section=view&module=list?s= 52cc06f5296148ce42b7d43511937640

Смущает вот это в конце ссылки 52cc06f5296148ce42b7d43511937640. После двух неудачных кликов это пропадает и нормально переходит. Ссылка становится нормальной.

Сразу скажу что форум нулевый. Это может быть из за этого? Сталкивался ли кто то с такой проблемой?

Edited by Scalpel

Share this post


Link to post
Share on other sites
Особенно такое в IE6, но пару раз заметил и в других браузерах.

Официально IE6 не поддерживается форумом.

 

 

Сразу скажу что форум нулевый. Это может быть из за этого? Сталкивался ли кто то с такой проблемой?

Возможно

Share this post


Link to post
Share on other sites
Официально IE6 не поддерживается форумом.

Возможно

 

Да, я читал что не поддерживается. Я бы забил. Но пару раз было такое в мозиле и ие8. Вот что беспокоит...

Share this post


Link to post
Share on other sites
Но пару раз было такое в мозиле и ие8. Вот что беспокоит...

Поймать плавающий глюк ...

Share this post


Link to post
Share on other sites

А не подскажете где вообще это можно искать? После ссылок добавляется хрень такая

7682a49a1d87902e3707a60820bf75c7

и только в верхнем меню :(

 

два раза кликаю на ссылку ничего, третий раз страница обновляется хрень исчезает и можно нормально ходить по меню :)

 

Включил режим отладки, вот что пишет внизу

 

Retreiving user agent information from the DB

Creating GUEST session: 0262b52d232184c1a9dadefc3f54d3cc

makeSeoTitle (guest) called

Gateway file confirmed: html

Skin set not found, setting default. Using set #1

Setting current module to: forums and current section to:

 

 

и вот это 0262b52d232184c1a9dadefc3f54d3cc как раз добавлятеся к ссылкам!!! Не знаете что это может быть? Заранее благодарю!

Edited by Scalpel

Share this post


Link to post
Share on other sites

Сессии.

В роботсе *s= надо запрещать.

Share this post


Link to post
Share on other sites
Сессии.

В роботсе *s= надо запрещать.

Подскажите, а какое отношение имеет роботс.тхт к открытиям ссылок из верхневого меню сайта? :) Я конечно попробывал, но это ничего не дало. Или вы что то другое имели ввиду?

Share this post


Link to post
Share on other sites
Включил режим отладки, вот что пишет внизу

 

Retreiving user agent information from the DB

Creating GUEST session: 0262b52d232184c1a9dadefc3f54d3cc

makeSeoTitle (guest) called

Gateway file confirmed: html

Skin set not found, setting default. Using set #1

Setting current module to: forums and current section to:

 

 

и вот это 0262b52d232184c1a9dadefc3f54d3cc как раз добавлятеся к ссылкам!!! Не знаете что это может быть? Заранее благодарю!

Как уже сказали, это номер сессии. Применяется для создании кук и идентификации пользователя.

 

Это нормально. У меня на локальной машине на тестовом форуме

 

Retreiving user agent information from the DB
Creating GUEST session: fec094ec94a3c68a6be9b9b24a25c85a
makeSeoTitle (guest) called
Gateway file confirmed: html
Skin set found via member's preferences. Using set #1
Setting current module to: forums and current section to:
Cookie loaded: itemMarking_forums_items - a:1:{i:3;i:1272268788;}
Cookie loaded: itemMarking_forums - b:0;
Cookie loaded: itemMarking_gallery_items - a:2:{i:5;i:1271143530;i:1;i:1270017424;}
Cookie loaded: itemMarking_gallery - a:1:{s:6:"greset";a:1:{s:0:"";i:1269882694;}}
Item Marking Key Created! 400d1e9cf505ab403e3c65d9bacd1a9f

 

Или для админа

Updating MEMBER session: af2ace3916e1d3071a2a7cdee867bd24
Gateway file confirmed: html
Skin set found via member's preferences. Using set #1
Setting current module to: forums and current section to: forums
Cookie loaded: itemMarking_gallery_items - a:2:{i:5;i:1270839578;i:1;i:1270839528;}
Cookie loaded: itemMarking_gallery - a:1:{s:6:"greset";a:4:{s:0:"";i:1269882080;i:2;i:1269883358;i:4;i:1270663092;i:3;i:1270662646;}}

 

Если гость переходит по меню Members, то получаем такую ссылку:

http://ipb3/index.php?app=members&section=view&module=list

 

Ссылка нормальная. Не нормально, что не переходит. Я вначале подумал о этом баге -- The session ID problem...

Но не уверен, что он ....

Share this post


Link to post
Share on other sites

Но уверен, что проблема в сессиях

Share this post


Link to post
Share on other sites
Но уверен, что проблема в сессиях

 

Да, посмотрел ссылку, чтото очень похожее, не совсем понимаю что англичане пишут :) . Буду разбираться

Спасибо!

 

В общем да, это моя проблема. Хоть переводчик коряво перевел, все равно понятно, что не нажимаются ссылки с первого клика, а если страницу обновить то все ок.

Разработчики выпустили фикс этого, если кому надо тут

У меня не заработало :)

И по отзывам у нескольких человек тоже. Но проблему закрыли :)

Edited by Scalpel

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...