Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Leon-lonely

Проблемы с отображением online/offline в темах

Recommended Posts

Возникла парочка вопросов по скинам в 3.1.

1. Онлаин/Офлаин пользователя..В Скине идет

						<if test="postOnline:|:$post['author']['_online']">
							{parse replacement="user_online"}
						<else />
							{parse replacement="user_offline"}
						</if>  

Вопрос - откудо это все береться...

2. В профиле пользователя, при попытке добавить комментарий выходит сообщение

[14:28:06] Реунок Татьяна Игоревна: Возникла ошибка. Если вы не уверены, что правильно используете функцию, советуем вам обратиться к нашей системе помощи за дополнительной информацией.

Подскажите, где копнуть.

 

Очень рассчитываю на Вашу помощь, ибо больше не к кому обратиться(

Share this post


Link to post
Share on other sites

1. parse replacement – вызов картинок/кода/текста через макросы. В данном случае, картинок, согласно заданному условию.

2. – вопрос с первым никак не связан. Думаю, что нужно правильно выставить права групп (маски доступа или иное), но причем тут шаблоны?

Share this post


Link to post
Share on other sites

1. parse replacement – вызов картинок/кода/текста через макросы. В данном случае, картинок, согласно заданному условию.

2. – вопрос с первым никак не связан. Думаю, что нужно правильно выставить права групп (маски доступа или иное), но причем тут шаблоны?

Со вторым разобрался...А вот со статусом пользователя никак(

Share this post


Link to post
Share on other sites

А что требуется, я не понимаю?

В скине прописано условие для вызова картинок. И все. Что нужно от скина еще?

 

test="postOnline:|:$post['author']['_online']"

Управление этим осуществляется не в скине.

Share this post


Link to post
Share on other sites

Проблема в том, что не смотря ни на что, показывается что юзер оффлаин:)

Причем в профиле со статусом пользователя все нормально, проблема только в темах, в постах

Edited by Leon-lonely

Share this post


Link to post
Share on other sites

Я где-то читала об этой проблеме (к сожалению, не помню где). Решается точно не в скине.

А в скине информация о пользователе в темах заложена в шаблоне

Глобальные (Global Templates) > userInfoPane

 

Тему переношу, ждите ответа программистов.

Share this post


Link to post
Share on other sites

Я где-то читала об этой проблеме (к сожалению, не помню где).

На ibresource.ru было. Был вопрос, еще до сегодняшнего. Ответа не было.

 

А у нас английская версия.

В моей песочнице, стоит русская версия. Система для сообществ IP.Board 3.1.1

Сейчас посмотрел, вроде бы все работает.

 

Сегодня понаблюдаю, посмотрю. Точно что в IP.Board 3.0.5 в этом куске кода расхождений между русской и английской версии не было.

 

В 3.1 надо смотреть. Появился ВКОНТАКТ :)

Share this post


Link to post
Share on other sites

Проблема в том, что не смотря ни на что, показывается что юзер оффлаин:)

Причем в профиле со статусом пользователя все нормально, проблема только в темах, в постах

Посмотрел код. Ошибки не вижу. Скорее всего дело не в этом...

 

юзер оффлаин - для всех? Всегда?

Share this post


Link to post
Share on other sites

Посмотрел код. Ошибки не вижу.

А ошибка есть :)

Share this post


Link to post
Share on other sites

IP.Board 3.1.0 было

 

		//-----------------------------------------
	// Joins
	//-----------------------------------------		

	$_post_joins = array(
							array( 
									'select' => 'm.member_id as mid,m.name,m.member_group_id,m.email,m.joined,m.posts, m.last_visit, m.last_activity,m.login_anonymous,m.title,m.hide_email, m.warn_level, m.warn_lastwarn, m.members_display_name, m.members_seo_name, m.has_gallery, m.has_blog, m.members_bitoptions,m.mgroup_others',
									'from'   => array( 'members' => 'm' ),
									'where'  => 'm.member_id=p.author_id',
									'type'   => 'left'
								),
							array( 
									'select' => 'pp.*',
									'from'   => array( 'profile_portal' => 'pp' ),
									'where'  => 'm.member_id=pp.pp_member_id',
									'type'   => 'left'
							),
							array( 
									'select' => 'g.g_access_cp',
									'from'   => array( 'groups' => 'g' ),
									'where'  => 'g.g_id=m.member_group_id',
									'type'   => 'left'
							)
						);

 

IP.Board 3.1.1 Стало

 

		//-----------------------------------------
	// Joins
	//-----------------------------------------		

	$_post_joins = array(
							array( 
									'select' => 'm.member_id as mid,m.name,m.member_group_id,m.email,m.joined,m.posts, m.last_visit, m.last_activity,m.login_anonymous,m.title,m.hide_email, m.warn_level, m.warn_lastwarn, m.members_display_name, m.members_seo_name, m.has_gallery, m.has_blog, m.members_bitoptions,m.mgroup_others',
									'from'   => array( 'members' => 'm' ),
									'where'  => 'm.member_id=p.author_id',
									'type'   => 'left'
								),
							array( 
									'select' => 'pp.*',
									'from'   => array( 'profile_portal' => 'pp' ),
									'where'  => 'm.member_id=pp.pp_member_id',
									'type'   => 'left'
							),
							array( 
									'select' => 'g.g_access_cp',
									'from'   => array( 'groups' => 'g' ),
									'where'  => 'g.g_id=m.member_group_id',
									'type'   => 'left'
							),
							array( 
									'select' => 's.running_time',
									'from'   => array( 'sessions' => 's' ),
									'where'  => 's.member_id=m.member_id',
									'type'   => 'left'
							)
						);

 

Ошибка исправлена и в русской, и английской версии IP.Board 3.1.1.

Вот поэтому у нас все нормально...

 

Для исправление в IP.Board 3.1.0 в файле admin/applications/forums/modules_public/forums/topics.php Найти первый фрагмент и заменить на второй.

  • Upvote 1

Share this post


Link to post
Share on other sites

Огромное спасибо. Помогло)

И возник еще вопрос - не работает кнопка Удалить, а кнопка Редактировать кидает сразу на полное редктирование поста, без ajax'а. Так же при просмотре темы...Движок 3.1.0...

Share this post


Link to post
Share on other sites

Cookies почистите в браузерах, которыми пользуетесь.

хм..удаление заработало, спасибо. Но с редактированием проблема осталась

Share this post


Link to post
Share on other sites

Ph-A, спасибо большое мне тоже помогло!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...