Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
костя1

После конвертации phpBB3 в IPB3 не отображаются старые сообщения

Recommended Posts

Помогите пожалуйста,После конвертации phpBB3 в IPB3 не отображаются старые сообщения.

Не знаю что делать.

Share this post


Link to post
Share on other sites

После конвертации phpBB3 в IPB3 не отображаются старые сообщения.

Точно конвертация прошла до конца? Все перерасчеты запускали?

Share this post


Link to post
Share on other sites

Точно конвертация прошла до конца? Все перерасчеты запускали?

Проблема была решена,база данных была в Cp1251

Share this post


Link to post
Share on other sites

Здравствуйте! Решил не создавать новую тему. Отпишусь тут. Симптомы аналогичные. После конвертации из phpbb3 в ipb3 часть сообщений перестала отображаться в темах. Обе БД в UTF. И в новой IPBшной базе все посты в таблице присутствуют. Все синхронизации проводил. В html коде страницы сообщений так же нет. Куда копать? Подскажите!!

Share this post


Link to post
Share on other sites

И в новой IPBшной базе все посты в таблице присутствуют.

Если действительно все посты есть в базе, но не все отображаются, то тут могут быть следующие варианты:

a ) не правильно установлен topic_id (посты на форуме совсем не выводятся)

b ) проблема с кодировкой. И тут речь не только о "сравнении" collation таблицы, но и в какой кодировке находятся данные в ней (сообщения есть, но пустые)

c ) посты скрыты/отправлены на премодерацию. Правда, в таком случае они бы совсем не стали отображаться, но мало ли.

 

У вас судя по всему проблема скорее всего именно с кодировкой данных.

Share this post


Link to post
Share on other sites

а ) проблема думаю не в этом, потому как посты выводятся выборочно. Предполагаю если бы напутан был topic_id то вообще никакие сообщения не выводились бы.

b )как я уже писал обе базы(по сути база даже одна, таблицы просто имеют разный префикс) в utf единственное таблицы phpbb в utf_bin, a таблицы ipb в utf_general_ci. И Еще меня смущает тип таблиц. В IPB базе часть таблиц с типом MyISAM а часть InnoDB. Это может влиять?

с ) тут точно нет. по крайней мере в админке в разделе одобрения постов ни одного не присутствует.

Edited by gods33

Share this post


Link to post
Share on other sites

Как я уже писал, "сравнение" collation не обеспечивает и не гарантирует нужную кодировку данных.

http://dev.mysql.com/doc/refman/5.5/en/charset-general.html

 

A collation is a set of rules for comparing characters in a character set.

 

Т.е. если у вас таблица и данные в ней были в cp1251 и вы просто поменяли collation, это не значит что данные теперь стали в utf8. Их нужно еще конвертировать. Кроме того, где-то могло произойти и автоматическая перекодировка в ненужную кодировку если соединение было установлено не правильно. А что с новыми постами, кстати?

 

Еще меня смущает тип таблиц. В IPB базе часть таблиц с типом MyISAM а часть InnoDB. Это может влиять?

Тип таблицы немного из другой области, и относится к структуре хранения данных mysql. Вряд ли причина в этом.

  • Upvote 1

Share this post


Link to post
Share on other sites

Т.е. если у вас таблица и данные в ней были в cp1251 и вы просто поменяли collation, это не значит что данные теперь стали в utf8. Их нужно еще конвертировать. Кроме того, где-то могло произойти и автоматическая перекодировка в ненужную кодировку если соединение было установлено не правильно. А что с новыми постами, кстати?

То есть необходимо попробовать переконвертировать всю БД в UTF ?

 

А новые посты сначала отображаются а потом через какое-то время пропадают, причем опять же выборочно...

Share this post


Link to post
Share on other sites

вообщем решил проблему переконвертацией данных. Видимо первый раз как-то криво конвертнулось. Спасибо siv1987, что откликнулся на проблему!

Share this post


Link to post
Share on other sites

Все забываю отписаться тут. Сейчас вот вспомнил. Проблему свою "решил", как я писал выше, переконвертацией. Но не надолго. Со временем стали пропадать даже те посты, которые писались после конвертации. Очень долго гуглив наткнулся на небольшую, так сказать, заметку. Человек описывал такие же симптомы и как у него оказалось всему виной был хук "Спасибо". Меня и осенило, так как у меня тоже такой присутствовал. Только хуки разные у нас были, но я решил попробовать. Как только его отключил сразу же все сообщения появились. Мой хук назывался Ajax Thanks. Да, я понимаю что тема о другом, но как оказалось это тоже может быть причиной, а человек будет сопоставлять это с другими действиями. Может кому пригодится.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...