Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Minnow

502 Bad Gateway + [#20312]

Recommended Posts

Здравствуйте.

 

3.0.5 При попытке "Отметить все сообщения прочитанными" появляется сначала post-39527-041089800 1280777986_thumb.jpg

 

при повторной попытке post-39527-018776500 1280778029_thumb.jpg

 

либо сразу post-39527-018776500 1280778029_thumb.jpg

 

при этом пользователь авторизован.

Что не так сделал?

 

Спасибо.

Share this post


Link to post
Share on other sites

По 502 Bad Gateway разобрались, осталась ошибка [#20312].

Share this post


Link to post
Share on other sites

3.0.5 При попытке "Отметить все сообщения прочитанными"

[3.0.5] Session ID in URL

И так же очень полезно в

Панель управления > Настройки и инструменты > Системные настройки > Настройки Cookies

Пропишите домен и можно путь.

Share this post


Link to post
Share on other sites

По 502 Bad Gateway разобрались

Рано радовался .. 502 Bad Gateway жива и продолжает существовать при "Отметить все сообщения прочитанными" и никакие "танцы с бубнами" не помогают. Может быть причина в 3.0.5 ? На сервере все настройки отвечают требованиям IPB 3.*.* .

Share this post


Link to post
Share on other sites

Может быть причина в 3.0.5 ?

502 Bad Gateway это ошибка сервера. К форуму не имеет не какого отношение

 

На сервере все настройки отвечают требованиям IPB 3.*.* .

nginx стоит?

Share this post


Link to post
Share on other sites

502 Bad Gateway это ошибка сервера. К форуму не имеет не какого отношение

 

 

nginx стоит?

Да, стоит - nginx/0.5.33

Share this post


Link to post
Share on other sites

А чего такой свежий-то?)

 

Размер proxy_buffer_size увеличьте, к примеру, до 64k.

Share this post


Link to post
Share on other sites

Размер proxy_buffer_size увеличьте, к примеру, до 64k.

Не помогло.

 

server_names_hash_bucket_size 64;

# proxy_buffer_size 64k;

# fastcgi_buffers 4 32k;

# fastcgi_buffer_size 32k;

# proxy_buffers 4 32k;

Edited by Minnow

Share this post


Link to post
Share on other sites

Если это цитата вашего конфига, то вы что-то не то сделали :)

 

Если nginx используете как прокси, то речь о proxy_buffer_size, иначе о fastcgi_buffer_size. Увеличивают их чтобы заголовок ответа сервера пролезал с огромной кукой.

Share this post


Link to post
Share on other sites

Вот фрагмент лога, который мне прислал хостер, может быть это что либо прояснит:

(таких схожих фрагментов очень много, для всех ресурсов одного айпи)

 

user nicname;
worker_processes 1;

error_log /var/log/nginx/error.log;
pid /var/run/nginx.pid;

events {
   worker_connections 1024;
}

http {
   include /etc/nginx/mime.types;
   default_type application/octet-stream;

   access_log /var/log/nginx/access.log;

   sendfile on;
   #tcp_nopush on;

   server_names_hash_bucket_size 64;
# proxy_buffer_size 64k; 
# fastcgi_buffers 8 32k; 
# fastcgi_buffer_size 32k; 
# proxy_buffers 4 32k;



   #keepalive_timeout 0;
   keepalive_timeout 65;
   tcp_nodelay on;

   gzip on;

   include /etc/nginx/sites-enabled/*;

client_max_body_size 100m;
               client_header_buffer_size 32k;
               large_client_header_buffers 8 32k;
   proxy_max_temp_file_size 32k;


server {
 listen *.*.*.79:80;
 server_name domain.ru www.domain.ru domain.ru;
 rewrite ^(/manager/.*)$ https://$host$1 permanent;
 rewrite ^(/manager/.*)$ https://$host$1 permanent;
 location ~* ^/(webstat/|awstats|webmail/|myadmin/|manimg/) {
  proxy_pass http://*.*.*.79:8080;
  proxy_redirect http://domain.ru:8080/ /;
  proxy_set_header Host $host;
  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  proxy_set_header X-Real-IP $remote_addr;
 }
 location / {
  proxy_pass http://*.*.*.79:8080;
  proxy_redirect http://domain.ru:8080/ /;
  proxy_set_header Host $host;
  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  proxy_set_header X-Real-IP $remote_addr;
 }
 location ~* ^.+\.(jpg|jpeg|gif|png|svg|js|css|mp3|ogg|mpe?g|avi|zip|gz|bz2?|rar)$ {
  root /var/www/domain/data/www/domain.ru;
  access_log /var/www/httpd-logs/domain.ru.access.log;
  error_page 404 = @fallback;
 }
 location @fallback {
  proxy_pass http://*.*.*.79:8080;
  proxy_set_header Host $host;
  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  proxy_set_header X-Real-IP $remote_addr;
}
}

Share this post


Link to post
Share on other sites

Я не специалист в настройках серверов.

Прошу по возможности, кто в этом хоть как то разбирается, можете дать готовый конфиг?

 

Спасибо.

Share this post


Link to post
Share on other sites
server {
 listen *.*.*.79:80;
 server_name domain.ru www.domain.ru domain.ru;
 rewrite ^(/manager/.*)$ https://$host$1 permanent;
 rewrite ^(/manager/.*)$ https://$host$1 permanent;
 location ~* ^/(webstat/|awstats|webmail/|myadmin/|manimg/) {
  proxy_pass http://*.*.*.79:8080;
  proxy_redirect http://domain.ru:8080/ /;
  proxy_buffer_size 64k; 
  proxy_buffers 4 64k;
  proxy_set_header Host $host;
  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  proxy_set_header X-Real-IP $remote_addr;
 }
 location / {
  proxy_pass http://*.*.*.79:8080;
  proxy_redirect http://domain.ru:8080/ /;
  proxy_buffer_size 64k; 
  proxy_buffers 4 64k;
  proxy_set_header Host $host;
  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  proxy_set_header X-Real-IP $remote_addr;
 }
 location ~* ^.+\.(jpg|jpeg|gif|png|svg|js|css|mp3|ogg|mpe?g|avi|zip|gz|bz2?|rar)$ {
  root /var/www/domain/data/www/domain.ru;
  access_log /var/www/httpd-logs/domain.ru.access.log;
  error_page 404 = @fallback;
 }
 location @fallback {
  proxy_pass http://*.*.*.79:8080;
  proxy_buffer_size 64k; 
  proxy_buffers 4 64k;
  proxy_set_header Host $host;
  proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
  proxy_set_header X-Real-IP $remote_addr;
}
}

Share this post


Link to post
Share on other sites

Танцы с бубнами длились достаточно долго .. Ничего не помогало, никакие конфиги. А ларчик открывался просто. Вообще эта проблема (моя проблема) оказалась из разряда "йа дерево" .. Ну не хостер я .. Имея доступ к некоторым настройкам сервера, я не имел возможности перезагрузить его. И как оказалось - настройки вступили в действие сразу после перезагрузки сервера хостером. Поэтому прошу прощения за беспокойство и хочу сказать спасибо всем кто откликнулся (включая ЛС).

Существует проблема с IE, тормозит форум при работе с этим браузером. Но это видимо уже другая тема.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...