Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Nicker

Время последнего собщения

Recommended Posts

Подскажите как исправить время последнего сообщения на форуме, отображается не "Вчера, 22:57", а в как время в UNIX "1285441040" это только в некоторых шаблонах, вот к примеру у шаблона Paradox 3.1 все нормально, а у reStyleIPB3 3.1 нет, версия форума 3.1.2, заранее спасибо.

Share this post


Link to post
Share on other sites

все нашол где поправить сам.

 

в boardIndexTemplate и forumIndexTemplate:

 

Ищем

 {$forum_data['last_post']}

 

Меняем на

 

{parse date="$forum_data['last_post']" format="LONG"}

Edited by Nicker

Share this post


Link to post
Share on other sites

все нашол где поправить сам.

Это не секрет. Только править придется и другие вещи. Это не единственное изменение в скине.

Share this post


Link to post
Share on other sites

Пока вроде все гуд, да и кстати заметил еще одну вещь в globalTemplate:

<if test="isfloat:|:is_float($stats['ex_time'])">{$this->lang->words['stats_sec']}</if>

толь к не знаю за что она отвечает, но вроде работает все гуд, перелазил пересмотрел все.

Share this post


Link to post
Share on other sites

все нашол где поправить сам.

 

в boardIndexTemplate и forumIndexTemplate:

 

Ищем

 {$forum_data['last_post']}

 

Меняем на

 

{parse date="$forum_data['last_post']" format="LONG"}

сделал но все так же

Share this post


Link to post
Share on other sites

Поддерживаю, версия 3.1.2. скин Лайт для версии 3.1.2 - грабли те же, при чем только при выводе списка форумов и подфорумов, даты последних сообщений выводятся корректно. Спасибо.

Share this post


Link to post
Share on other sites

Нид Хелп, после перехода с версии 3.0.3 на 3.1.2 - появилась проблема о которой писал выше, но даты показываются не цифрами а везде в виде - 01 Янв 1970 02:00, такая бага только при выводе списка форумов на главной странице и подфорумов, с темами все ок.

Поставил тестовый форум на локальную машину, все прекрасно показывает на стандартном скине и Скине Лайн Фисаны.

На рабочем форуме - корректно показывает только на старом скине IPB, на новых везде такая проблема.

Я понимаю что где-то что-то не обновилось или обновилось криво.

Ткните носом какие файлы проверить и какие именно отвечают за запросы и вывод этих дат на главной странице :)

Заранее сенкью :)

Share this post


Link to post
Share on other sites

Всем спасибо, нашел и исправил, напортачили когда обновляли.

Share this post


Link to post
Share on other sites

все нашол где поправить сам.

 

в boardIndexTemplate и forumIndexTemplate:

 

Ищем

 {$forum_data['last_post']}

 

Меняем на

 

{parse date="$forum_data['last_post']" format="LONG"}

 

После этого нормализовались лишь даты на главной форума и для подфорумов. При выводе списка тем подфорума проблема осталась, решилась так:

в forumIndexTemplate также находите:

{$data['last_post']}

Заменяете на

{parse date="$data['last_post']" format="LONG"}

Share this post


Link to post
Share on other sites

Сделал как все тут написано, время вместо цифр теперь показывается только на главных страницах форума, когда же переходишь внтурь раздела, то в темах вместо дат тем, так и остался уникод.

Edited by siv1987

Share this post


Link to post
Share on other sites

у меня 3.4.5 там код по другому. обоих местах у каждого 2 таких строк изменить все 4?

 

 

boardIndexTemplate:

{parse date="$forum_data['last_post']" format="DATE"}

forumIndexTemplate:

{parse date="$forum_data['last_post']" format="DATE"}

Edited by DrBarcode

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...