Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
stiliar

IP.Gallery 2.1.2 в Opera и в Firefox

Recommended Posts

В IE всё нормально, но в вышеперечисленных браузерах вот такая "накладка", в прямом и переносном смыслах этого слова:

post-5767-1174379153_thumb.jpg

Что интересно: на InvisionPower.com такая же версия галереи отображается нормально во всех браузерах.

Предпологаю, что надо что-то в шаблонах подправить, но что и где - не знаю.

Сравнил исходный код страниц, нашел такое различие:

У них -

<div class="thumb" style='height: 148px; vertical-align: middle;'>

У меня -

<div class="thumb" style='height: 20px; vertical-align: middle;'>

 

Может и не в этом причина, но это то, что бросилось в глаза. Я так пологаю, что это в CSS-файле должно правиться, но просмотрев файл, я не нашел там ничего подобного.

Fisana, ты уже "собаку съела" на этих инвижновских шаблонах :rolleyes: , может знаешь, в чем дело?

Share this post


Link to post
Share on other sites

Вот не поленилась скриншот сделать из оперы.

У меня ни в одном браузере проблем нет. Они в этой версии исправили много багов, в том числе со скриптами и шаблонами.

В этом скине в шаблонах галереи изменен немного только один - это исправление бага, который затем тоже ips исправили.

Впрочем в новой версии скина я оставила все как есть, и шаблонов для галереи, следовательно, там совсем нет - только графика. Шаблоны достраиваются из вашего базового...

С галереей все нормально, если это нормальная версия, и со скинами тоже проблем нет, если структура максимально дефолтная. А тут она именно такая.

gallery.png

Share this post


Link to post
Share on other sites

Fisana, спасибо за отзывчивость и извини, что отнимаю твое драгоценное время, но не могла бы ты подсказать в каком файле искать ошибку или в каких html-фрагментах?

Чувствую себя полным ламером. Я иногда своим пользователям отвечаю точно также, как ты: мол, у меня все нормально, а у вас просто руки кривые. А теперь вот сам на их месте. Но я и не собираюсь становиться профессором по отладке скриптов Invision, просто нет времени для углубленного изучения структуры. Мне бы хотябы примерно знать, где искать, а то я как в темном лесу. Кстати, забыл сказать, в IE хоть и нормально отображается, но в строке статуса показано, что загрузилось с ошибками на странице. Значит где-то в html-коде ошибки. Но где?.. Какие фрагменты отвечают за главную страницу галереи? Или за вывод 5 случайных и 5 последних изображений?

Share this post


Link to post
Share on other sites

Вроде исправил, причем совершенно случайно. В Админке:

Components->IP.Gallery->Category Manager->Member's Gallery->Edit Category

Я сюда залез, чтобы исправить "Member's Gallery" на "Галерея пользователей" и затем заметил такую настройку: Member's Gallery Settings->Display Method. У меня там стояло такое:

Show Individual Albums, я изменил на Group Listing by Member. Сохранил настройки и все нормализовалось.

Share this post


Link to post
Share on other sites

Я бы все равно не смогла ответить на предпоследний пост, так как не сталкивалась с этой проблемой и не знаю где копать.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...