Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Storok

IPB 3.2.2 Авторизация через Twitter

Recommended Posts

Не работает авторизация через Twitter. Перекидывает на обычную страницу входа. В логах ничего нету. Интересно то, что интеграция уже зарегесрированного пользователя с Twitter проходит без проблем.

Share this post


Link to post
Share on other sites

У вас энергия так и прет. Может, захотите поучаствовать в наполнении и развитии другого форума с долгой историей, вместо создания своего нового с нуля? :)

 

По теме же - только что все получилось:

Screenshot-4.jpg

 

Ага, вижу, это только регистрация работает, а вот авторизация действительно не проходит. И еще почему-то авторизация у вас не запрашивает доступа на то, чтобы постить в твиттер... Вы точно правильный тип приложения в твиттере выбрали при создании?

 

Only Good Anime Forum by Only Good Anime

App to sign in.

read-only access · Approved: Sun October 16, 2011 11:31:07

 

Против:

IP.Board Company Forums by Invision Power Services, Inc.

Twitter integration for the official Invision Power Service company forums.

read and write access · Approved: Wed November 10, 2010 11:06:01

 

Другие IPB-форумы тоже "read and write access" запрашивали, а ваш - только read...

Share this post


Link to post
Share on other sites

Спасибо.

 

Пойду изменю приложение.

 

P.S Регистрацию и не пробовал даже :)

Share this post


Link to post
Share on other sites

Изменил придожение. Теперь переходит на Твиттер без проблем. После нажатия на Вход перекидывает на страницу обычного входа на форуме.

Share this post


Link to post
Share on other sites

Вобщем....нашол в чём причина:)

Раньше перекидывало после твитера на страницу входа!

 

заходим в : admin/sources/classes/twitter/connect.php

 

Незнаю что в нём не так было, но вот код с которым всё работает!

 

Код взят с версии 3.4.5

 

Это то, что должно храниться в этос connect.php

Залил себе на форум, можете сами проверить.

Share this post


Link to post
Share on other sites

Незнаю что в нём не так было, но вот код с которым всё работает!

 

$this->request['reg'] нужно заменить на $this->request['_reg']

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...