Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Puristaako

После изменения сообщения не закрывает форму

Recommended Posts

Надо подправить сообщение, жму Изменить, вношу изменения, жму Сохранить и... ничего, форма так и остается открытой. Если в другом окне зайти, то видно, что изменения внесены.

 

Вносил большое количество изменений в скин, т.к. многое он неумел, возможно, что то лишнее удалил/изменил, подскажите что должно там быть, чтобы закрывал форму и загружал измененное сообщение.

Edited by Puristaako

Share this post


Link to post
Share on other sites

Так используйте кнопку "Сравнить" над кодом шаблона. Вам подсветит все ваши правки, и там уже найдете, чего поломали. Скорее всего, какой-нибудь важный id затерли у одного из элементов.

  • Upvote 1

Share this post


Link to post
Share on other sites

Так используйте кнопку "Сравнить" над кодом шаблона. Вам подсветит все ваши правки, и там уже найдете, чего поломали. Скорее всего, какой-нибудь важный id затерли у одного из элементов.

В каком именно месте искать? Какой шаблон? Как в стандартном это место выглядит? Я переменные и т.п. не удалял, только внешний вид подгонял, а то скин не поддерживал категории у форумов, пришлось самому приделывать.

Edited by Puristaako

Share this post


Link to post
Share on other sites

Востановите стандартный скин (просто создайте новый - он автоматически будет стандартным)

Проверьте, работает ли там.

Если там работает, а в измененной версии не работает, по очереди в шаблонах отменяйте (делая бэкап, чтобы вернуть потом) свои правки.

Мы не телепаты и не можем угадать, где косяки.

Share this post


Link to post
Share on other sites

Тоже не работает на стандартном скине

Share this post


Link to post
Share on other sites

Скажите просто где код который отвечает за кнопку эту?

Share this post


Link to post
Share on other sites

Если и в стандартном не работает, попробуйте перезалить /public/js из дистрибутива

Share this post


Link to post
Share on other sites

Сделал как вы сказали - не помогло.

Сейчас обновил форум до 3.2.3 (с огромнымипроблеммами из-за хостера, но обновился)...

Жму изменить -> сохранить и вылазит вот это:

 

[#103118] Темы не существует.

 

Содержимое сообщения сохранено!

Данные следующего сообщения успешно сохранены. Иногда случается, что при нажатии на кнопку «Назад» заполненные в поля данные теряются, поэтому вы можете скопировать текст и только потом вернуться на предыдущую страницу.

Содержимое сообщения сохранено!

 

Сообщение не изменяется.

Share this post


Link to post
Share on other sites

Попробуйте отключить все нестандартные хуки и перестройте кэш.

Проверяйте на стандартном скине.

 

Но возможно, это какие-то проблемы с конфигурацией сервера.

Share this post


Link to post
Share on other sites

А ничего и нет нестандартного, зачем воротить если всё и так работает. Кэш перестраивал буквально час назад.

Попробовал создать форум без кириллицы в названии, чтобы ссылка была целиком латиницей - тот же результат.

Edited by Puristaako

Share this post


Link to post
Share on other sites

А ничего и нет нестандартного

Форум в Board URL верный? Тогда странное у вас мнение о стандартности.

 

Попробовал создать форум без кириллицы в названии, чтобы ссылка была целиком латиницей - тот же результат

А браузер не пробовали сменить.

 

Сейчас обновил форум до 3.2.3

Более глючной версии, не видел. ИМХО.

Share this post


Link to post
Share on other sites

Мнение о стандартности у меня точно такое же как и всех, ничего не изменено по сравнению с оригиналом - стандарт. Спросили про хаки, модификации там ничего не стоит кроме дефолтных. Если вы про тему то проверяю я на дефолтной, то что сейчас стоит это платная тема, которую приходиться подгонять под себя, но кроме разметки ничего не меняется, ещё раз - проверяю я на дефолтной теме, внизу можете переключить и посмотреть

 

add: во попка... :) сам решил переключить на другой скин посмотреть просто и переключил на старый под 3.0, потом обратно, удалил его (старый стиль) и теперь захожу через эксплорер он пишет:

 

 

Warning: require_once(/home/u46271/tennisofficialr/www/public//style_images/master/_php/loader.php) [function.require-once]: failed to open stream: No such file or directory in /home/u46271/tennisofficialr/www/cache/skin_cache/cacheid_12/skin_global.php on line 380

 

Fatal error: require_once() [function.require]: Failed opening required '/home/u46271/tennisofficialr/www/public//style_images/master/_php/loader.php' (include_path='.:/usr/local/lib/php:/home/u46271/tennisofficialr/www/ips_kernel/') in /home/u46271/tennisofficialr/www/cache/skin_cache/cacheid_12/skin_global.php on line 380

 

через админку пользователю сменил скин обратно, не помогает, через другие браузеры все нормально :) он кэшированную старую, с ошибками выдает что-ли? Ладно это не важно, с первым надо разобраться

Edited by Puristaako

Share this post


Link to post
Share on other sites

Очень похоже на то, что проблема была "на той стороне". (я про изменение сообщения)

Сегодня всё заработало, хотя абсолютно никаких изменений не проводилось. Даже новых постов не было.

К тому же у мажордомо тогда же когда была замечена эта проблема периодически блокировался аккаунт, "превышение 15% ЦПУ" (правила у них такие), сейчас, тьфу тьфу тьфу всё нормально, похоже они меня на другой сервер переносили и забыли что-то на нем включить из-за этого и вылазила проблема.

Edited by Puristaako

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...