Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Boo_Ar

Проблема! Ошибка БД в IPB 3.1.4 при чтение темы

Recommended Posts

Здравствуйте, у меня возникает ошибка базы данных при попытке читать тему.

Date: Wed, 30 Nov 2011 00:48:26 +0000
Error: 1054 - Unknown column 'm.name' in 'field list'
IP Address: 95.108.244.252 - /index.php?/topic/27-%d1%87%d1%82%d0%be-%d1%82%d0%b0%d0%ba%d0%be%d0%b5-%d0%b3%d0%b0%d0%b9%d0%b4-faq/page__pid__32
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
mySQL query error: SELECT p.*,m.member_id as mid,m.name,m.member_group_id,m.email,m.joined,m.posts, m.last_visit, m.last_activity,m.login_anonymous,m.title,m.hide_email, m.warn_level, m.warn_lastwarn, m.members_display_name, m.members_seo_name, m.has_gallery, m.has_blog, m.members_bitoptions,m.mgroup_others,pp.*,pc.*,rep_index.rep_rating as has_given_rep,rep_cache.rep_points,cca.*,ccb.cache_content as cache_content_sig, ccb.cache_updated as cache_updated_sig FROM ipbposts p  LEFT JOIN ipbmembers m ON ( m.member_id=p.author_id ) 
LEFT JOIN ipbprofile_portal pp ON ( m.member_id=pp.pp_member_id ) 
LEFT JOIN ipbpfields_content pc ON ( pc.member_id=p.author_id ) 
LEFT JOIN ipbreputation_index rep_index ON ( rep_index.app='forums' AND 
					             rep_index.type='pid' AND 
					             rep_index.type_id=p.pid AND 
					             rep_index.member_id=0 ) 
LEFT JOIN ipbreputation_cache rep_cache ON ( rep_cache.app='forums' AND rep_cache.type='pid' AND rep_cache.type_id=p.pid ) 
LEFT JOIN ipbcontent_cache_posts cca ON ( cca.cache_content_id=p.pid ) 
LEFT JOIN ipbcontent_cache_sigs ccb ON ( ccb.cache_content_id=m.member_id )   WHERE p.pid IN(32) ORDER BY pid asc
.--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.
| File                                                                       | Function                                                                      | Line No.          |
|----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|
| admin/applications/forums/modules_public/forums/topics.php                 | [public_forums_forums_topics]._getTopicDataLinear                             | 426               |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'
| admin/sources/base/ipsController.php                                       | [public_forums_forums_topics].doExecute                                       | 285               |
'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

 

Я понимаю, что отсутствует столбец в таблице, а в какой именно таблице и как починить?

И из-за чего могла возникнуть данная проблема?

Share this post


Link to post
Share on other sites

Обратите внимание

"Board url", указанный вами в профиле, некорректен, либо недоступен на данный момент. Пожауйста, заполните его, потому что он скорее всего потребуется при диагностике вашей проблемы.

Он доступен. ;)

Share this post


Link to post
Share on other sites

Проблема сохраняется.

Уже пробовал через SQL запрос создать не достающий столбец и все равно ошибка. :(

Share this post


Link to post
Share on other sites

Попробуйте проверить таблицы и восстановить поврежденные. Должно помочь

  • Upvote 1

Share this post


Link to post
Share on other sites

у меня та же проблема.

восстанавливаю, работает, потом падает...

восстанавливаю, опять через некоторое время...

Share this post


Link to post
Share on other sites

восстанавливаю, работает, потом падает...

Какая таблица рушится?

 

восстанавливаю, опять через некоторое время...

Слабый хостинг. Не хватает ресурсов. При нехватке первой страдает сервер базы данных. Что сказывается на целостность таблиц.

Share this post


Link to post
Share on other sites

Какая таблица рушится?

Таблица: posts - жму восстановить таблицу, восстанавливается, но уже 3 раз за день опять сыпется.

хотя, уже 4 часа держится )))

 

Слабый хостинг. Не хватает ресурсов. При нехватке первой страдает сервер базы данных. Что сказывается на целостность таблиц.

хостинг неплохой, 10Гб для форума, трафик неограниченный...

Edited by Bulick

Share this post


Link to post
Share on other sites

хостинг неплохой

По каким критериям? На хорошем хостинге, сервер MySQL настроен.

 

10Гб для форума

Угу. Очень значимый параметр, место на диске. Очень влияет на работу форума.

 

трафик неограниченный...

Любой трафик ограничен.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...