Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Alexander Benoit

3.2.2 | Форум не хочет отображать аватары.

Recommended Posts

Поиск юзал, гугл юзал, яндекс юзал, мозги и руки тоже юзал...

Значица после перееезда форум перестал отображать аватары (на форуме было только 2 пользователя и без аватаров).

В системных настройках пути до папки Upload тоже правил.

Поясню: картинка подгружается при смене аватара, но вместо неё выдаётся alt "Изображение". При этом картинки спокойно ложаться в папку Upload/Profiles (CHMOD на обе папки 750).

Правил функции PHP на хосте:

upload_max_filesize 20m 20m

upload_tmp_dir /tmp /tmp

 

А вот какую информацию об изображении выдаёт Мозилла:

ab1dfcf65d88.jpg

 

В чём может быть проблема?

Share this post


Link to post
Share on other sites

А вот какую информацию об изображении выдаёт Мозилла:

 

Прямая ссылка на картинку -

 

404 Not Found

The resource requested could not be found on this server!
Powered By LiteSpeed Web Server
LiteSpeed Technologies is not responsible for administration and contents of this web site!

 

А что хостер говорит?

Share this post


Link to post
Share on other sites

Прямая ссылка на картинку -

 

404 Not Found

The resource requested could not be found on this server!
Powered By LiteSpeed Web Server
LiteSpeed Technologies is not responsible for administration and contents of this web site!

 

А что хостер говорит?

 

Лайфчат не работал, пришлось слать им на почту, но по скольку у меня нету доступа к почте владельца самого сайта ответ ТП скинуть сейчас не смогу.

Но всё заработало сразу же после отправки запроса в ТП. Видать их трабл. Видать наконец то(за 2 последних) дня попался нормальный сотрудник в ТП. Хост ихц ру...

К вечеру скину ответ.

 

UPD: пришёл ответ.

Исправили права для каталогов forum/uploads и forum/uploads/profile

Теперь картинки отображаются.

 

Ага, ну да...я значицо вчера весь вечер с этим CHMOD'ом ковырялся, а они бац и сделали)) ну ну))

И до этого сегодня утром про CHMOD с их ним же сотрудником общался в лайф-чате...и он меня уверял, что всё нормально...

Edited by Alexander Benoit

Share this post


Link to post
Share on other sites

Видать их трабл

С самого начала так подумал.

Share this post


Link to post
Share on other sites

А у меня почему-то аватары начали юзать картинку профиля у пользователей. В настройках капаюсь, поиск ничего не выдал. Какая настройка отвечает за то что бы автары и профили фотографий были разные? АЦ на русском

 

Вроде бы при обновлении выбрал пункт аватары.

Edited by kerimchik

Share this post


Link to post
Share on other sites

Какая настройка отвечает за то что бы автары и профили фотографий были разные?

В 3,2 нет такой настройки. Теперь везде используется фотография.

Есть еще такое в АЦ:

Инструменты > Пересчет и перестроение > Инструменты очистки

Конвертировать аватары/фотографии из IPB 3.1 в фотографии IPB 3.2

Share this post


Link to post
Share on other sites

В 3,2 нет такой настройки. Теперь везде используется фотография.

Есть еще такое в АЦ:

Инструменты > Пересчет и перестроение > Инструменты очистки

Конвертировать аватары/фотографии из IPB 3.1 в фотографии IPB 3.2

 

Сделал, не помогло. Фотография в профиле видна, а вот аватарка нет. Т.е. при нажатии на аватар - что бы нашел путь до картинки, он мне выдает линк http://mysite.ru/uploads По идеи должен быть http://mysite.ru/uploads/av-1.jpg

Где я накосячил?

Я пока тестовый установил на локалке. Так что пока проблем нету, но при реалке - не хотел бы сталкиваться с такой проблемой :)

А как правильно сделать обновление при реалке? При запросе обновлении аватаров, что нужно сделать? И если я не увижу аватары после обновления, какое первое действие должен сделать?

 

П.С. после установки нового аватара, все нормально стало. Ссылка на аватар и на фотографию стало единой. Т.е. ссылка на обоих идет http://mysite.ru/uploads/profile/photo-1.gif

Странно :)

Edited by kerimchik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...