Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Liberia

Не срабатывает пароль на подфорум

Recommended Posts

Добрый день

 

суть проблемы: есть подфорумы, доступ к которым осуществляется по паролям, который можно ввести в админке форума. После обновления форума до версии 3.4.5 перестали работать пароли (переустановка их не помогает). Войти в подфорум невозможно висит надпись, даже если пароль верен:

Этот форум защищен паролем

Этот форум защищен паролем!

Вы должны ввести правильный пароль, чтобы попасть в этот форум. Пожалуйста, удостоверьтесь, что в Вашем веб-браузере включены cookies

 

Даже куда "копать" непонятно. Помогите, пожалуйста

Share this post


Link to post
Share on other sites
Обратите внимание

По указанному вами в профиле "Board url" находится не IP.Board, либо модифицированный пиратский скрипт с удаленными копирайтами. Если вы указали неверный URL, пожауйста, поправьте его, потому что он скорее всего потребуется при диагностике вашей проблемы. Нелицензионные скрипты не приветствуются, т.к. зачастую именно некорректное "нуление" и является причиной проблем в них.

Share this post


Link to post
Share on other sites

В пароле случайно русские символы не используются?

Share this post


Link to post
Share on other sites

нет, не используются. Пробовала только цифрами, результат тот же

Share this post


Link to post
Share on other sites

Видимо, стоит копать в сторону "обновлялись с версии 2.х.х до версии 3.4.5 без промежуточных конвертаций" или же кодировка базы данных. Отдайте на растерзание профессионалу и дайте немного денег.

Share this post


Link to post
Share on other sites

нет, не видимо

 

обновлялись с версии 3.1.4 с промежуточными конвертациями на 3,2 и 3,3

с кодировкой тоже все нормально

Edited by Liberia

Share this post


Link to post
Share on other sites

Возможно, стоит написать в техподдержку IPS.

Share this post


Link to post
Share on other sites

А шаблон соответствует версии форума? На стандартном стиле не пытались?

Share this post


Link to post
Share on other sites

да, шаблон соответствует версии форума.

В стандартнйо версии выдает тоже самое

Этот форум защищен паролем

Этот форум защищен паролем!

Вы должны ввести правильный пароль, чтобы попасть в этот форум. Пожалуйста, удостоверьтесь, что в Вашем веб-браузере включены cookies

 

при всем этом настройка "Освобожденные группы - Если у вас включен ввод пароля, то вы можете выбрать группы, которые смогут просматривать этот форум без ввода пароля."

Работает отлично.

Share this post


Link to post
Share on other sites

стоит копать в сторону "кривоватости" некоторых браузеров

например google chrome иногда на каком-либо адресе некорректно отдаёт пароль

пробовать другие браузеры

Share this post


Link to post
Share on other sites

Имхо, тогда без доступа к форуму и исходникам я не знаю чем еще можно помочь. Протестировал функцию на 3.4 - никаких проблем нету.

Share this post


Link to post
Share on other sites

Оно всегда при обновлении с версии на версию криво что-то бывает. Нет способа просто взять и накатить. Стартёру темы нужно нанимать специалиста или писать в техподдержку насчёт своего бага.

Edited by Zero108

Share this post


Link to post
Share on other sites

Вряд ли проблема в обновлении, так как система проще паренной репы. Я не удивлюсь если виной какой-то хук, или баг в шаблоне.

Кстати, справа должен быть код ошибки (решетка с пятизначной цифрой), какой код показывает?

  • Upvote 1

Share this post


Link to post
Share on other sites

в разных браузерах ошибка повторяется.

В стандартном шаблоне тоже ошибка на месте.

 

Кода ошибки нет. Там окно всплывает после ввода пароля "Вам был предоставлен доступ к этому форуму", может поэтому ошибки нет. Оно всплывает после отправки пароля, страница обновляется, но остается та же форма ввода пароля (хм, может здесь затык? не перенаправляет на нужный форум?)

 

 

Что касается наема специалистов, то мой опыт говорит о том, что уровень "специалистов" таков, что на большинсвто вопросов они не знают ответов. И все равно все заканчивается вопросами на форумах, где коллективный разум оказывается сильнее. Поэтому не надо давать беспристанно один и тот же совет, если больше ничем помочь нет возможности.

Share this post


Link to post
Share on other sites

Там окно всплывает после ввода пароля "Вам был предоставлен доступ к этому форуму", может поэтому ошибки нет.

Возможно какие-то проблемы с кукисами.

 

 

Что касается наема специалистов, то мой опыт говорит о том, что уровень "специалистов" таков, что на большинсвто вопросов они не знают ответов. И все равно все заканчивается вопросами на форумах, где коллективный разум оказывается сильнее. Поэтому не надо давать беспристанно один и тот же совет, если больше ничем помочь нет возможности.

Здесь речь не о вопросе, а о специфичном баге. Вы такой "вопрос" задайте любому разработчику - вас или попросят доступ к скриптам или же сразу отправят к экстрасенсам. Вы замечаете что в этой теме с "коллективным разумом" нет ни одного конкретного ответа, все абстрактно с догадками и предположениями?

  • Upvote 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...