Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Одмин

VK-видео на форуме

Recommended Posts

Залил файл, установил хук, добавил медиа тег, но не работает

"Не работает" - понятие обширное. Что конкретно не работает? Какую ссылку использовали при проверке? Инструкцию читали?

  • Upvote 1

Share this post


Link to post
Share on other sites

Здравствуйте.

При вставке кода видео, оно даже отображается в сообщении, но как только наживаешь кнопку отправить, видео исчезает.

Помогите разобраться.

70f72a914824.png

bade6bfeb3f7.png

Share this post


Link to post
Share on other sites

Помогите разобраться.

Вы вставляете iframe.

В стандартном функционале и в этой теме нет такого ббкода [vkvideo]. Читайте документацию по своему кастомному ббкоду. Здесь обсуждается медиа-тег и хук который преобразовывает прямые ссылки на видео.

Share this post


Link to post
Share on other sites

А вот так выглядит прямая ссылка

 

7e649538dc1b.png

Share this post


Link to post
Share on other sites

vkvideo - такого бб кода у ipb нету. Если вы его устанавливали отдельно прочитайте руководство по его использованию, если не устанавливали - тогда ничего работать не будет.

Share this post


Link to post
Share on other sites

vkvideo - такого бб кода у ipb нету. Если вы его устанавливали отдельно прочитайте руководство по его использованию, если не устанавливали - тогда ничего работать не будет.

я говорю про медиа-тег, код которого брал и менял со второго сообщения в этой теме.

ecf153ef04f0.png

7ca0131e6d31.png

Edited by vitfix

Share this post


Link to post
Share on other sites

Медиа тег не нужно обрамлять в бб коды, просто вставляется ссылка и все.

Для медиа тега смотрите его формат и убедитесь что вставляете правильную ссылку. Судя по вашему скриншоту она не соответствует формату (код и текст нужно приводить текстом а не скриншотом). Рекомендую прочитать тему целиком.

Share this post


Link to post
Share on other sites

Медиа тег не нужно обрамлять в бб коды, просто вставляется ссылка и все.

Для медиа тега смотрите его формат и убедитесь что вставляете правильную ссылку. Судя по вашему скриншоту она не соответствует формату (код и текст нужно приводить текстом а не скриншотом). Рекомендую прочитать тему целиком.

Вот так выглядит прямая ссылка на видео. Вставлял через медиа

Share this post


Link to post
Share on other sites

Чтобы прямые ссылки работали нужно дополнительно еще установить хук. Без хука работают только ссылки из ифрейма. Перечитайте пожалуйста тему, об этом здесь уже разжеванно.

Share this post


Link to post
Share on other sites

Чтобы прямые ссылки работали нужно дополнительно еще установить хук. Без хука работают только ссылки из ифрейма. Перечитайте пожалуйста тему, об этом здесь уже разжеванно.

Так в том то и дело, что хук поставлен.

Share this post


Link to post
Share on other sites

Добрый день, будет ли работать этот хук на 3.1.4 ?

Share this post


Link to post
Share on other sites

Так в том то и дело, что хук поставлен.

Хук обновлен. Вк изменил верстку страницы откуда берется хеш.

 

 

Добрый день, будет ли работать этот хук на 3.1.4 ?

Нет. В 3.1 другой парсер сообщений и другая логика classPost::formatPostForCache от чего есть проблемы с кешем.

Share this post


Link to post
Share on other sites

У меня версия 3.3.4

 

Все видео, где предусмотрено использование IFRAME - не показываются.

Линк преобразовывается в соответствии с медиатегом и в сообщении показывается: <iframe и так далее

Касается видео с фэйсбука, вконтакте и фликр

Перечитал все актуальные темы на форуме, ставил два хука на ФБ и ВК сделанные siv1987 - но безрезультатно

 

Ютуб показывается нормально. Наверное потому что там нету IFRAME в замене медиатега.

 

То есть пытаясь локализовать проблему, она в IFRAME

Права на HTML есть, как на раздел форума, так и на юзера/группу

Где копать? повторяю, версия 3.3.4

 

Спасиб

Share this post


Link to post
Share on other sites

Можно как то сделать видео с вконтакте и фэйсбука без IFRAME ?

 

Не могу понять почему IFRAME не срабатывает

 

<iframe src="http://www.facebook.com/video/embed?video_id=1111888822228888" width="640" height="400" frameborder="0"></iframe>

 

Помогите разобраться, пожалуйста

Share this post


Link to post
Share on other sites

Вы случайно не перепутали ифрейм с медиа-тегом? Еще раз повторяю - никакие права хтмл здесь не нужны, медиа-тег это ссылка которая заменяется по шаблону - вставлять нужно только ссылку.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...