Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
karamelka

502 bad gateway при массовом удалении тем.

Recommended Posts

Переехала на vps

Процессор

Intel® Xeon® CPU E5-2670 v2 @ 2.50GHz 2499.996 Mhz

Оперативная память

8388608 kB

Файл подкачки (swap)

4194304 kB

nginx/1.6.2

 

панель isp manager lite

 

Стоит форум 3.4.6.

При массовом удалении тем вылазит ошибка 502 bad gateway

 

Понимаю что надо что-то изменить в настройках nginx, но за не имением опыта не пойму как и что.

 

Аналогичные темы читала, но так ничего и не поняла. Там говорится об ошибке 504. У меня что-то другое кажется.

Причем даже если тему одну удалять, но не изнутри темы а при выдаче через поиск например, появляется ошибка

Edited by karamelka

Share this post


Link to post
Share on other sites

Темы таки удалились, толкьо не понятно как. Сейчас проверить не могу т.к. тем нет.

В настройках nginx изменила некоторые параметры

worker_connections с 1024 до 2048

keepalive_timeout с 65 до 20

worker_processes с 1 до 2

 

это должно улучшить работу?

Share this post


Link to post
Share on other sites

У меня режим php как модуль Apache

 

Создайте тикет для устранение недочета, по логам они поймут, что куда. А так можете попробовать изменить параметры PHP, у себя решил так, повышением "Ограничением времени выполнения скрипта - PHP" и Увеличиваем PHP memory limit

 

Безымянный.png

Edited by Атаман

Share this post


Link to post
Share on other sites

php memory limit у меня и так стоит 128, а вот время 300. если поставить 600 от этого нагрузка не увеличится на сервер?

Share this post


Link to post
Share on other sites

Темы таки удалились, толкьо не понятно как. Сейчас проверить не могу т.к. тем нет.

В настройках nginx изменила некоторые параметры

worker_connections с 1024 до 2048

keepalive_timeout с 65 до 20

worker_processes с 1 до 2

 

это должно улучшить работу?

 

Из-за того что задача была запущена, и время скрипта подошло к концу, и вылезла белая страница, но процесс продолжал свою работу.

Share this post


Link to post
Share on other sites

Не должно. Это значение обычно по умолчанию стоит.

Share this post


Link to post
Share on other sites

Темы таки удалились, толкьо не понятно как. Сейчас проверить не могу т.к. тем нет.

В настройках nginx изменила некоторые параметры

worker_connections с 1024 до 2048

keepalive_timeout с 65 до 20

worker_processes с 1 до 2

 

это должно улучшить работу?

 

На заметку.

+ интересно Nginx настраивать в панеле управления - заходите в (Под руут) - www домены - Ваш домен - Конфиг -

 

Безымянный.png

Share this post


Link to post
Share on other sites

я настраивала в etc/nginx/nginx.conf

Share this post


Link to post
Share on other sites

я настраивала в etc/nginx/nginx.conf

 

Можно и так, то я на заметку показал. Для быстроты.

Share this post


Link to post
Share on other sites

При массовом удалении тем вылазит ошибка 502 bad gateway

502 bad gateway означает, что nginx не дождался ответа от апача (если он используется в качестве прокси сервера) по таймауту - задача отрабатывает слишком долго. Не советую начать менять все конфиги подряд.

  • Upvote 1

Share this post


Link to post
Share on other sites

вобщем не помогли настройки так и выдает ошибку 502 при удалении тем через поиск(даже 1 шт)

в чем же причина

Share this post


Link to post
Share on other sites

Чтоб не разводить длинную тему, напишите в поддержку на хостинге, пусть логи поглядят. Возможно сервер подстроить нужно. Какой режи у домена Апаче или FASTCGI ?

Share this post


Link to post
Share on other sites

Сколько грузится страница прежде чем выдать ошибку? При других действиях проблем нету?

Share this post


Link to post
Share on other sites

Сколько грузится страница прежде чем выдать ошибку? При других действиях проблем нету?

при других проблем нет. выдает моментально

Edited by karamelka

Share this post


Link to post
Share on other sites

То есть нажали и сразу bad gateway, при этом весь остальной форум работает нормально?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...