Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
marik768

https SSL сертификат

Recommended Posts

на сайте установле SSL сертификат, он он отоброжается только тогда когда нажму на главную страницу форума и проподает..

визде в настройках указан адресс как с https

post-57734-0-97701700-1432455718_thumb.png

но в админ панели все прекрасно отоброжается, использую стиль карбона при использовании стандартного стиля пишет "Удаленный сервер или файл не найден" хотя раньше работал !

не чего нового не делал за последнее время, само собой появилось..

Share this post


Link to post
Share on other sites

Адрес форума в том числе с протоколом указывается в conf_global.php

Share this post


Link to post
Share on other sites

Указал, с стандартным стилем исправил - теперь он работает и у него показывает SSL сертификат(обновил кеши) но в стиле карбона все еще не работает..

получается на стандартном работает а на карбоне нет!

 

ps у меня еще редирект с http на https, думаю проблема в каких-то настройках стиля.

Share this post


Link to post
Share on other sites

Обновите кеши стилей.

Адреса форума от стиля не зависят. От стиля зависит url'ы графики стиля.

Share this post


Link to post
Share on other sites

Конечно уже пытался визде кеши обновлять, во всех стилях даже перестанавливал стили..

но а что это тогда, на ст стиле работает на других нет :blink:

Share this post


Link to post
Share on other sites

Честно говоря у меня нет ни желания ни времени тем, кто указывает в Board URL: test.ru объяснять каким образом работают стили, формируются ссылки и разводить философские дискуссии на то, что вы подразумеваете под "на стиле не работает". Указывайте правильный адрес форума в board url и пишите конкретно что значит "не работает".

Share this post


Link to post
Share on other sites

мне кажется, я ясно изложил суть проблемы. от вас многого не жду, стало интересно может кто имел эту проблемы и ее тут решали.. но судя по вам и откликам это "превью"..

 

раз так, пусть так..

Share this post


Link to post
Share on other sites
мне кажется, я ясно изложил суть проблемы. от вас многого не жду, стало интересно может кто имел эту проблемы и ее тут решали..

Вам кажется. Ясно - это когда вы конкретно приводите какие url'ы где и как не работают, с каким протоколом подключаются стили и графика данного шаблона.

Адрес форума определяется на уровне конфигурационного файла, и он должен быть единым для всей системы. В шаблоне адрес форума не должен переопределятся. Если у вас это происходит, то вам нужно очно показаться специалисту или самостоятельно провести обследование скина на переопределения адреса.

 

А вообще-то я вижу что никаких проблем с протоколом нету. Системные ссылки форум генерирует согласно адресу форума.

 

ps у меня еще редирект с http на https

Нет у вас редиректа. С "Server: nginx" еще нужно настроить правильно веб-сервер чтобы скрипты запускаемые бэкендом могли определить по какому протоколу произошел запрос пользователя. Либо ставить редирект на уровне виртуального хоста.

Отсюда видимо и ложное представление о том, что проблема "в стиле", так как форум может открываться по тому и по другому протоколу. Вот почему важно правильно указывать адрес форума и показать пациента специалистам а не заниматься составлением диагнозов клизмой. Мне без труда удалось отыскать ваш форум, но вы должны понимать когда задаете вопрос, что в первую очередь в решение проблемы заинтересованы Вы. Специалист, который ценит свое и чужое время не станет у Вас выпрашивать данные как будто он вам здесь чем-то должен. Удачи.

 

но судя по вам и откликам это "превью".

По мне вы судить не можете, ибо мы с вами не знакомы. Чтобы судить как специалиста вы сами должны обладать достаточной компетентностью в этом вопросе. А насчет откликов то моя репутация говорит сама за себя. Я не раз говорил, что у меня негативное отношение к пользователям которые заведомо указывают ложные данные при этом задают вопросы из области "у меня не работает форум что делать все пропало!!!". Я понимаю что школа, каникулы, первые прыщи, первый форум на хостингере, пубертатный период и все дела - времени у таких людей полно.

  • Upvote 2

Share this post


Link to post
Share on other sites

У меня на главной странице ssl работает,но только перехожу в темы,замок открыт.В чём может быть проблема?

Да,и ещё,что это означает? открыть в защищенном режиме У меня выключено

Share this post


Link to post
Share on other sites

Скорее всего на странице подключаются объекты по простому протоколу http://. Как правило это касается изображений и медиа контента в сообщениях, скриптов счетчиков и прочих виджетов с других ресурсов.

Браузеры требуют чтобы содержимое защищенной https странице подключалось также по безопасному протоколу, в противном случае объекты которые подключаются по обычному протоколу могут быть изменены третьей стороной и влиять на ее безопасность. Поэтому такие страницы показываются с открытым замком ssl.

Ищите в исходном коде страницы встраеваемые теги script, img, iframe, object, которые используют обычный протокол http://

Share this post


Link to post
Share on other sites

Бывает просто темы создаю,после создания темы ошибка 500,приходится перезаходить на форум,и так же после этого замок открыт.

Share this post


Link to post
Share on other sites
Ищите в исходном коде страницы

CTRL + U

Share this post


Link to post
Share on other sites

Нету ни чего кроме https

 

А вообще спасибо ВАМ большое за помощь!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...