Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Amix

Проблемы при переносе форума

Recommended Posts

Может баян, но все же.

Проблема в том что при переносе форума возникла проблема

There appears to be an error with the database.
If you are seeing this page, it means there was a problem communicating with our database. Sometimes this error is temporary and will go away when you refresh the page. Sometimes the error will need to be fixed by an administrator before the site will become accessible again. 

База весит 16мб, а phpmyadmin не дает заливать больше 10мб, поэтому залил через панель ispmgr

Share this post


Link to post
Share on other sites

щас вот что пишет

Your settings could not be read by IP.Board. This is a fatal error and IP.Board cannot function while this issue persists.

Share this post


Link to post
Share on other sites

Это видел уже, в ispmgr ставлю кодировку utf8, все равно не помогает

Share this post


Link to post
Share on other sites

Не правильно переносите.

 

1. Бэкап и импорт нужно делать через sympex dumper 2. Кодировка должна быть указана utf8.

2. На новом хостинге создать базу данных в utf8. Развернуть бэкап через сайпекс.

3. Убедится что в /conf_global.php для sql_charset указано utf8.

 

Если у вас возникают проблемы с кодировкой то, либо один из этих пунктов не соблюден, либо у вас изначально была проблемнная кодировка базы которую нужно исправить для дальнейшего нормально переноса.

Share this post


Link to post
Share on other sites

$INFO['sql_charset']			=	'utf8';

 

Увеличил в phpmyadmin размер загружаемого файла, загрузил через и все равно так же, кодировки стоят везде utf8

Share this post


Link to post
Share on other sites

через sympex dumper 2 залил, ошибка осталась, бэкап базы делался давно и уже не помню через что, а как проверить проблемная кодировка или нет?)

Share this post


Link to post
Share on other sites

бэкап базы делался давно и уже не помню через что, а как проверить проблемная кодировка или нет?)

Открыть бэкап в расширенным текстовом редакторе такой как notepad++ и посмотреть. Буквы должны быть читаемы а кодировка стоять utf-8. Если бэкап делался давно и весит всего лишь 16 Mb есть смысл установить форум с нуля без него.

Share this post


Link to post
Share on other sites

Все хорошо читается, кодировка стоит utf-8, нужна именно эта база, какие у вас еще есть думки по этому поводу, как востановит?

Share this post


Link to post
Share on other sites

Откройте через phpMyAdmin таблицу {префикс}cache_store, найдите поле "settings" и вставьте туда значение:

нету такого поля...

 

остальное сделал не помогает, и делал запрос

UPDATE {префикс}cache_store SET cs_value='a:2:{s:10:"mail_queue";i:0;s:13:"task_next_run";s:10:"1246017960";}' WHERE cs_key = 'settings';

говорит строк 0, выполнено 0

Share this post


Link to post
Share on other sites

нету такого поля...

Это не поле, а запись. Создайте новую запись с ключом settings и указанным значением.

Share this post


Link to post
Share on other sites

Плохо дружу с базой, не правильно сделал?

 

 

Ощибка стала вот такая щас

 

Там, кажется, ошибка с базой данных.

Если вы видите эту страницу, значит произошла ошибка соединения с нашей базой данных. Иногда эта ошибка имеет временный характер и проходит после обновления страницы. Иногда ошибки должны быть исправлены Администратором, прежде чем сайт станет доступным снова.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...