Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
El Loco

PHP to HTML для IPB 2.3.3

Recommended Posts

Имеется форум версии 2.1.7. Хочу перейти на 2.3.3.

Установлен мод PHP to HTML для 2.1.7. Будет ли он работать на 2.3.3? Если нет, то где можно скчать версию мода, рвботающую на 2.3.3?

Share this post


Link to post
Share on other sites

запрос в бд будет вот таким, если мне не изменяет память

INSERT INTO `ibf_conf_settings` ( `conf_title` , `conf_description` , `conf_group` , `conf_type` , `conf_key` , `conf_value` , `conf_default` , `conf_extra` , `conf_evalphp` , `conf_protected` , `conf_position` , `conf_start_group` , `conf_end_group` ,  `conf_add_cache` )
SELECT  'Enable PHP to HTML conversion ?', 'Before enable this features you must right set .htaccess file.', conf_title_id, 'yes_no', 'php_to_html', '', '0', '', '', '1', '127', 'Converter Settings', '1', '1'
FROM ibf_conf_settings_titles WHERE conf_title_keyword LIKE ('general')

Share this post


Link to post
Share on other sites

Спасибо.

Такой вопрос еще возник.

Если я сделаю апдейт, слетают все моды само собой, но, когда я ставил этот мод, то я же ведь уже делал этот запрос к базе. Необходимо ли повторно делать этот запрос при повторной установке мода на 2.3.3? Не будет ли каких-то косяков в связи с этим?

Есть вариант такой: перед апдейтом почистить базу от модов с помощью D21-[Tool]_Remove_DB_Customizations. А потом как бы с чистого листа ставить моды заново.

Но у меня помимо мода php2html есть еще thanks mod. И мне не хочется обнулять благодарности, которые уже записаны в базе.

Как бы вы посоветовали мне поступить?

Понимаю, что выхожу за рамки темы, но так уж получилось, что один вопрос тянет за собой следующий :)

Share this post


Link to post
Share on other sites

если уже ставили, то запрос можно не делать :)

главное делать бэкапы

Share this post


Link to post
Share on other sites

ясненько. спасибо!

а бекапы это святое :)

Share this post


Link to post
Share on other sites

А как для IPB 2.3.4 сделать ЧПУ?

Share this post


Link to post
Share on other sites

Ставьте мод от urisoft'а (он выложен в архиве на ibresource.ru), но используйте запрос, приведенный выше, вместо того, что в описании мода.

Share this post


Link to post
Share on other sites
Ставьте мод от urisoft'а (он выложен в архиве на ibresource.ru), но используйте запрос, приведенный выше, вместо того, что в описании мода.

Спасибо! Всё работает.

Share this post


Link to post
Share on other sites

А есть ли вообще смысл ставить этот мод?

Спасибо! Всё работает.

Не видит IP.Portal просто кидает в main.html, а так вроде всё нормально переводит.

Share this post


Link to post
Share on other sites

да. :lol: там есть недочет в регулярных выражениях. Толи в .htaccess, толи в class_display.php

Share this post


Link to post
Share on other sites
да. :lol: там есть недочет в регулярных выражениях. Толи в .htaccess, толи в class_display.php

в .htaccess :)

Share this post


Link to post
Share on other sites

Не могли бы вы подсказать что означает "запрос к базе данных"? Я новичок в этом и плохо понимаю.

Share this post


Link to post
Share on other sites

АЦ -> ПРОЧЕЕ -> Инструменты (SQL).

 

внизу будет поле ввода запроса

Share this post


Link to post
Share on other sites

Добрый день уважаемые!

 

В общем столкнулся с такой проблемой, был установлен IPB 2.3.2, на него установил ЧПУ (как на этом форуме), все работало супер. Купил лицензию, обновил форум до 2.3.5, вручную сделал исправления в файлах.

И начались косяки: заходишь в форум, выбираешь тему, наводишь на топик, ссылка статичная все ок, если войти в тему из "последнее сообщение в теме" то ссылка выглядит в php типа showtopik22.php?и_т.д

 

выполнил следущие действия:

Проверил в корне .htaccess все нормально..

Проверил файлы, в которых делал исправления, все сделал правильно.

Попробовал выключить и включить мод заново, не помогло.

Отключил-включил форум, не помогло.

Выполнил запрос к БД заново, не помогло..

 

Помогите пожалуйста как решить проблему?

Заранее благодарен.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...