Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
MILoTR

И снова про спойлер для ipb 2.3.6...

Recommended Posts

Доброго времени суток. Я воспользовался поиском по форуму, но ответа на свой вопрос так и не нашёл... Вот мод спойлера http://www.ibresource.ru/forums/index.php?showtopic=16522 Для его применения нужно отредактировать 4 файла: - sources/lib/post_parser.php

// - jscripts/ipb_global.js

// - jscripts/ipb_bbcode.js

// - lang/*/lang_post.php

Но,как я понимаю, в версиях 2.3.х произошли изменения в представлении bbcode, так как файл // - jscripts/ipb_bbcode.js , в котором нужно

"найти:

 

var HTML_open = 0;

 

 

добавить после:

 

var SPOILER_open = 0; "

отсутствует в дистрибутиве форума. Не могли бы вы подсказать решение проблемы?(только,пожалуйста, не советуйте способ, когда можно использовать только спойлер, без переменных(

[spoiler][/spoiler]

, мне желательна возможность и такого, и

[spoiler=][/spoiler]

) Заранее спасибо.

Share this post


Link to post
Share on other sites

Вам лучше поискать другой мод. Их не так уж и мало. :)

С 2.0.х многое изменилось :)

Share this post


Link to post
Share on other sites
Вам лучше поискать другой мод. Их не так уж и мало. :)

С 2.0.х многое изменилось :)

Согласен, что их достаточно много, но, к сожалению, это единственный из 6 модов такого типа, известных мне,который поддерживает спойлер с переменной(( Если Вам известны какие-либо моды,подходящих под это условие, не могли бы Вы предоставить ссылку на них? Буду весьма признателен :)

Edited by MILoTR

Share this post


Link to post
Share on other sites
IP.Board версия: 1.x

И зачем вы тогда мод от 2.0 решили поставить? :)

 

Понимаю, на самом деле у вас 2.1 или 2.3? Тогда ставьте http://www.ibresource.ru/db/994/ :)

Share this post


Link to post
Share on other sites
И зачем вы тогда мод от 2.0 решили поставить? :)

 

Понимаю, на самом деле у вас 2.1 или 2.3? Тогда ставьте http://www.ibresource.ru/db/994/ :)

Sannis, просто регистрировался я здесь, когда у меня ещё и форума-то не было :) Да,у меня 2.3.6.... То, что Вы посоветовали, не поддерживает переменные((

Share this post


Link to post
Share on other sites
То, что Вы посоветовали, не поддерживает переменные((
что значит "не поддерживает переменные"?
может есть ещё какие хорошие варианты, но для 2.3.х ?
этот мод стоит у меня на форуме 2.3.х

 

Саннис тоже не дурак и в ипб разбирается. Он бы несовместимое не стал бы советовать.

Share this post


Link to post
Share on other sites

спасибо, попробую поставить

Share this post


Link to post
Share on other sites
что значит "не поддерживает переменные"?

Ну, он может использоваться только так :

[spoiler][/spoiler]

, а мне нужно

[spoiler=Что-то][/spoiler]

Share this post


Link to post
Share on other sites

А вы перед тем как писали сообщение, на мод смотрели? Я думаю нет.

 

он это поддерживает. На скриншоте ясно показано, что туда и картинку вставляли.

Share this post


Link to post
Share on other sites
А вы перед тем как писали сообщение, на мод смотрели? Я думаю нет.

 

он это поддерживает. На скриншоте ясно показано, что туда и картинку вставляли.

Смотреть-то я смотрел, и даже установил его. У меня получается лишь подставить текст в теги

[spoiler][/spoiler]

, при этом, когда его редактируешь,теги меняются на

[spoiler=Раскрывающийся текст][/spoiler]

, и при попытке отправить отредактированное сообщение выдаёт следующее: Ошибка использования BB кодов форума. Возможно вы неправильно использовали какой-то из тегов, как, например, тег [TAG], тогда как он должен использоваться в виде [TAG=] или наоборот. Ну и,естественно,то же самое при попытке подставить другое значение вместо Раскрывающегося текста...

Проверил 2 раза,вроде всё точно по инструкции...Единственное,там не сказано,что файл expand.js нужно переименовать в spoiler.js ,но это я поправил.

Edited by MILoTR

Share this post


Link to post
Share on other sites

Читайте тему поддержки внимательно. Насколько я помню, там нужно стандартный спойлер удалить ещё.

 

По крайней мере у меня и у автора мод работает :)

Share this post


Link to post
Share on other sites
Читайте тему поддержки внимательно. Насколько я помню, там нужно стандартный спойлер удалить ещё.

 

По крайней мере у меня и у автора мод работает :)

Да, точно))Я уже сам опытным путём дошёл до этого решения...Раньше как-то и не задумывался над тем, что это за убогая штука с затемнением текста в IPB, а она тоже называется спойлером) Спасибо за помощь :)

Share this post


Link to post
Share on other sites
И зачем вы тогда мод от 2.0 решили поставить? :rolleyes:

 

Понимаю, на самом деле у вас 2.1 или 2.3? Тогда ставьте http://www.ibresource.ru/db/994/ ;)

отличный просто спойлер, очень доволен, спасибо. правда кнопку пришлось рисовать и вставлять самому, но это не самое страшное. (если кому надо кнопку можете найти в атаче)

 

так же немного изменил css, выглядит теперь так

 

f9a5fd831218980f26.jpg

 

кому понравилось, код:

 

.sp-wrap	  { background: #E4EAF2; margin: 8px auto; width: 97%; clear: both; font-weight: bold; }
.sp-head-wrap { padding: 3px 6px 2px; border: 1px dotted #000; border-left: 4px solid #8394B2;  border-bottom: solid #C3CBD1; border-width: 1px 1px 1px 4px; clear: both;}
.sp-head	  { font-size: 11px; padding: 1px 14px 3px; margin-left: 6px; line-height: 18px; }
.sp-body	  { display: none; font-weight: normal; background: #F5F5F5; padding: 1px 6px 2px;; border: 1px dotted #000; border-left: 4px solid #8394B2;  border-width: 1px 1px 1px 4px; clear: both; border-top-width: 0; }
.clickable { cursor: pointer; }
.folded { display: block; background: transparent url(style_images/icon_plus_1.gif) no-repeat left center; padding-left: 14px; }
.unfolded { display: block; background: transparent url(style_images/icon_minus_1.gif) no-repeat left center; padding-left: 14px; }

post-24265-1238470438.gif

Share this post


Link to post
Share on other sites

Привет всем

Не подскажите где найти спойлер для ipb 2.3.6?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...