Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
Arsen1

Переход с ipb 2.3.6 на ipb 3

Recommended Posts

Вот последняя ошибка из лога папки cache:

Это уже на втором запуске?

При первом запуске, инсталятор успел обновить ряд таблиц. А на втором он уже о них спотыкается.

 

Your memory limit: 16M.

Это совсем никуда.

 

Сейчас бодаюсь с хостером чтобы увеличили хотя бы до 64Мб.

На local :)

Шанс есть, что обновление пройдет.

А работать точно будет.

 

Но я думаю пробелма не у memory limit, иначе ошибка была типа "Fatal error: Allowed memory size of XXX bytes exhausted (tried to allocate XXX bytes) in /www/..." Хотя могу ошибаться.

Если показ ошибок включен.

 

P.S. Прежде чем обновятся, проверьте не побились таблицы, после бекапов - востановления.

Share this post


Link to post
Share on other sites

Это совсем никуда.

Админ согласился поднять до 64, но что-то у него там "не получается" пока.

 

P.S. Прежде чем обновятся, проверьте не побились таблицы, после бекапов - востановления.

Проверил статус ОК.

 

Это уже на втором запуске?

Видимо не то скинул, действительно то было второй запуск. Вот что выдаёт при первом запуске.

 

 Error: 1054 - Unknown column 'bbcode_custom_regex' in 'field list'
IP Address: 95.111.111.11 - /forums/admin/upgrade/index.php?app=upgrade&workact=permsAndBbcode&st=0&section=upgrade&do=appclass

 

На local :)

Шанс есть, что обновление пройдет.

А работать точно будет.

Форум без проблем устанавливается с нуля, а вот обновляться не хочет :)

Share this post


Link to post
Share on other sites

Ребята, а кто то знает если ИПБ предлагает сервис с помощью перехода с 2.3 на 3.1? Типа покупаеш лайсенс 3.х, и они помогают перевести все старое. Или ИПБ этим не занимается и лохам вроде меня предлагают искать помощи на стороне?

Share this post


Link to post
Share on other sites

Если есть активная лицензия, переведут бесплатно по запросу.

Но если используете сторонние моды и скины, их не будут обновлять.

Share this post


Link to post
Share on other sites

Понял, не дурак, спасибо :rolleyes: У меня за 3 года весь форум МОДами перелопачен, там от оригинального кода только кусочки остались :) Фисана, извините если вопрос не по теме, а возможно ли в 2.3 сдеать некое подобие 3.х в плане тех иконок, которые под аватаром? ПМ, Фейсбук, добавить в друзья и так далее? Я искал по форуму, но как то не нашел темы об этом.

Share this post


Link to post
Share on other sites

Теоретически да. Но дешевле обновить форум.

Share this post


Link to post
Share on other sites

.У меня за 3 года весь форум МОДами перелопачен

Я бы посоветовал посмотреть похожие моды под тройку. Возможно все вопросы снимутся в течение двух-трех дней.

Share this post


Link to post
Share on other sites
mySQL query error: SELECT m.*, m.member_id as my_member_id,g.*,ccb.cache_content FROM ibf_members m LEFT JOIN ibf_groups g ON ( g.g_id=m.member_group_id )

LEFT JOIN ibf_content_cache_sigs ccb ON ( ccb.cache_content_id=m.member_id ) WHERE m.members_l_username='root'

 

SQL error: Table 'Esq.ibf_content_cache_sigs' doesn't exist

SQL error code: 1146

Date: Tuesday 28th December 2010 10:15:36 AM

 

 

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Date: Tue, 28 Dec 2010 10:15:36 +0000

Error: 1146 - Table 'Esq.ibf_content_cache_sigs' doesn't exist

IP Address: 93.178.71.123 - /admin/upgrade/index.php?app=upgrade&s=&section=index&do=login

----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

mySQL query error: SELECT m.*, m.member_id as my_member_id,g.*,ccb.cache_content FROM ibf_members m LEFT JOIN ibf_groups g ON ( g.g_id=m.member_group_id )

LEFT JOIN ibf_content_cache_sigs ccb ON ( ccb.cache_content_id=m.member_id ) WHERE m.members_l_username='root'

.--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------.

| File | Function | Line No. |

|----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------|

| admin/sources/loginauth/login_core.php | [iPSMember].load | 154 |

'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

| admin/sources/loginauth/internal/auth.php | [login_core].authLocal | 70 |

'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

| admin/sources/handlers/han_login.php | [login_internal].authenticate | 729 |

'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

| admin/setup/sources/legacy/3xx.php | [han_login].loginAuthenticate | 171 |

'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

| admin/setup/applications/upgrade/sections/index.php | [upgradeLegacy].authenticateLogIn | 45 |

'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

| admin/setup/sources/base/ipsController_setup.php | [upgrade_index].doExecute | 256 |

'----------------------------------------------------------------------------+-------------------------------------------------------------------------------+-------------------'

 

Вот такая ошибка при обновление, все в нужной кодировке. Все сделал по 1 сообщению. Форум 2.3.6

Share this post


Link to post
Share on other sites

Тут когда-нить кто нить бывает ? +)

Share this post


Link to post
Share on other sites

Я бы посоветовал посмотреть похожие моды под тройку. Возможно все вопросы снимутся в течение двух-трех дней.

К сожалению самый популярный МОД "army system" на тройку не встанет :)

Share this post


Link to post
Share on other sites

Тут когда-нить кто нить бывает ? +)

Сейчас бывают

 

К сожалению самый популярный МОД "army system" на тройку не встанет :)

Тогда да ...

Share this post


Link to post
Share on other sites

Есть уже стабильная версия тройки: форум+галерея+блог?

Share this post


Link to post
Share on other sites

подскажите плз, если кто знает как поправить.

 

После перехода везде в статистике форума, появляются квадратики вместо пробелов, там где число больше 1 000

post-42121-0-61227600-1301240213_thumb.jpg

 

посмотрел в шаблонах, за вывод этого числа отвечает $forum_data['topics'], пробовал обрезать пробелы функцией trim , или заменить символы с помощью str_replace, но тогда выдает ошибку синтаксиса

Edited by SimpleSign

Share this post


Link to post
Share on other sites

Обновил форум с 2.3.6 до 3.1.4. БД в UTF8, в .htaccess кодировка прописана. Сообщения с БД отображаются знаками вопроса. Помогите.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...