Jump to content
Дизайн и модификация Invision Power Board IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
bukasuka

Ошибка БД при обновлении.

Recommended Posts

Здравствуйте.

Кто может помочь с данной проблемой.При обновлении с ipb 3.0.5 на 3.1.0 на странице ...upgrade&do=templatecache вылетела ошибка бд.

Сама ошибка:

 

Error Number: 1064
Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ') AND ( ( css_set_id > 0 AND css_master_key='' ) OR ( css_set_id=0 AND css_maste' at line 1
Page: /admin/upgrade/index.php?app=upgrade&section=upgrade&do=templatecache
Debug: array (
 1 => 
 array (
   'file' => '/home/tfreemeg/public_html/ips_kernel/classDb.php',
   'line' => 1050,
   'function' => 'query',
   'class' => 'db_driver_mysql',
 ),
 3 => 
 array (
   'file' => '/home/tfreemeg/public_html/admin/sources/classes/skins/skinCaching.php',
   'line' => 704,
   'function' => 'fetchCSS',
   'class' => 'skinFunctions',
 ),
 4 => 
 array (
   'file' => '/home/tfreemeg/public_html/admin/sources/classes/skins/skinCaching.php',
   'line' => 561,
   'function' => 'rebuildCSSCache',
   'class' => 'skinCaching',
 ),
 5 => 
 array (
   'file' => '/home/tfreemeg/public_html/admin/setup/applications/upgrade/sections/upgrade.php',
   'line' => 1477,
   'function' => 'rebuildCSS',
   'class' => 'skinCaching',
 ),
 6 => 
 array (
   'file' => '/home/tfreemeg/public_html/admin/setup/applications/upgrade/sections/upgrade.php',
   'line' => 208,
   'function' => 'install_template_caches',
   'class' => 'upgrade_upgrade',
 ),
 7 => 
 array (
   'file' => '/home/tfreemeg/public_html/admin/setup/sources/base/ipsController_setup.php',
   'line' => 255,
   'function' => 'doExecute',
   'class' => 'upgrade_upgrade',
 ),
)
mySQL query error: SELECT *,INSTR(',,', CONCAT(',',css_set_id,',')) as theorder FROM skin_css WHERE css_set_id IN () AND ( ( css_set_id > 0 AND css_master_key='' ) OR ( css_set_id=0 AND css_master_key='root' ) ) ORDER BY css_group, theorder DESC

 

Edited by bukasuka

Share this post


Link to post
Share on other sites

Установщих не может обновить кэш.

Права выставлены 777 на эту папку?

 

Но в любом случае это можно сделать руками.

Попасть в админку и вручную обновить кэши шаблонов не получается?

Share this post


Link to post
Share on other sites

Извините,на какую папку?Кэш из админки не обновляется,ошибка баз данных.

Edited by bukasuka

Share this post


Link to post
Share on other sites

На папку Cache. В вашем дистрибутиве должна быть инструкция с описанием, какие права нужны для папок при установке.

Если найдете неправильные права и исправите, апгрейд можно запустить снова, вроде он должен продолжиться.

 

А еще кэш можно обновить запросом к базе.

  • Upvote 1

Share this post


Link to post
Share on other sites

Как вы много знаете. :) Права действительно стояли не правильно.Прямо сейчас проверить не выйдет потому что сейчас на этапе "Приложения" пропали все галочки и пишет "Ошибка: Необходимо выбрать приложения для обновления."Поэтому нужно всё заново заливать.Эх...

На этом спасибо.

----

Увы,проблема не решилась,абсолютно тот же результат.Не поделитесь как обновить кэш через запрос?

Edited by bukasuka

Share this post


Link to post
Share on other sites

Подождите ответа программистов, так как я не по этой части (мои знания так далеко не распространяются).

Share this post


Link to post
Share on other sites

И я не подскажу. Тоже не смотрел, не надо было.

Надо брать исходники и идти по шагам, смотреть как и что он делает при апгрейде. Это время :)

Вопрос больше к разработчикам.

 

Проще откатить все из бекапа и пробовать снова.

Share this post


Link to post
Share on other sites

Откатывал уже несколько раз.

Завтра поищу на форуме community.invisionpower.com. Были ли похожие ошибки.

 

Но скорее всего проблема в серверном окружение. Сколько памяти для PHP, какая версия PHP и MySQL?

Share this post


Link to post
Share on other sites


  •  
  • Версия php 5.2.12
  • Версия MySQL-сервера 5.0.87
  • Версия MySQL-клиента: 4.1.22
  • Памяти 24м

Хорошо если в серверном окружении.В скором собираемся переезжать на более престижный хостинг,как бы проблема не переехала с нами.

Share this post


Link to post
Share on other sites
Памяти 24м

А 3.1 просит 128...

Минимум можно поставить с 32-мя. Но русский язык, например, уже не загрузит при 32-х на английскую версию.

Share this post


Link to post
Share on other sites

Памяти 24м

Скорее всего это и есть причина.

 

Но русский язык, например, уже не загрузит при 32-х на английскую версию.

Через Translate Externally можно.

Share this post


Link to post
Share on other sites

Изменить нету возможности,php.ini отсутствует.До тех.поддержки достучаться сложно,да и учитывая что она англоязычная.При обновлении до 3.1.1 установщик предупреждал,что необходимо больше памяти,но установка прошла успешно,только вот языковой пакет не встал.А на 3.1 никаких нареканий небыло.

Так может ну её эту 3.1,сразу на 3.1.1,если есть возможность поставить русский язык.Только с Translate Externally я не знаком,не просветите?

Edited by bukasuka

Share this post


Link to post
Share on other sites

При обновлении до 3.1.1 установщик предупреждал,что необходимо больше памяти,но установка прошла успешно,только вот языковой пакет не встал.

Тогда дело не в памяти ...

 

Только с Translate Externally я не знаком,не просветите?

Для него нужна русификация не в виде xml, а в виде отдельной папки translate.

Для легальных пользователей -- http://community.invisionpower.com/files/file/3146-russian-language-pack-all-products/

( .tar.gz: exported "translate" folder (for those who have server memory errors when importing xml) )

 

Установка: My Control Panel > Look & Feel > Manage Languages

English (USA) справа выпадающее меню. Copy language pack...

Текущий язык копируется как еще один язык.

Меняем название и локаль Locale -- ru_RU.UTF-8

 

Затем в корне форума, где conf_global.php создаем директорию translate. В "русском языке" выбираем Translate Externally...

Языковые файлы копируются в папку translate. Их надо заменить на распакованные файлы из архива.

Затем "выбрать все" и "импортировать выбранные файлы".

Чтобы изменение вступили в силу надо кэшировать изменения.

 

Файлы в директории можно удалить, но только через админку.

  • Upvote 1

Share this post


Link to post
Share on other sites

Премного благодарен.Будем пробовать.

---

На другом хостинге 3.1 встала без проблем.

Edited by bukasuka

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...