Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
KODEAK

Iriska

Recommended Posts

Для автора скина. И для тех кто купил.

 

Проблема:

 

При нажатии на кнопку Редактировать в профиле пользователя, будучи залогинненым под аккаунтом администратора, отображает несуществующую страницу.

 

Решение проблемы.

 

Идем АЦ--->Iriska---> Профили пользователей ---> profileModern

 

Ищем:

 

<li><a href='{parse url="app=core&module=modcp&section=editmember&auth_key={$this->member->form_hash}&mid={$member['member_id']}&pf={$member['member_id']}" base="public"}'>{$this->lang->words['supmod_edit_member']}</a></li>

 

Заменяем на:

<li><a href='{parse url="app=core&module=modcp&do=editmember&auth_key={$this->member->form_hash}&mid={$member['member_id']}&pf={$member['member_id']}" base="public"}'>{$this->lang->words['supmod_edit_member']}</a></li>

 

Заменяется параметр section на do.

 

Сделано на основе сравнения со стандартным стилем IPB.

  • Upvote 2

Share this post


Link to post
Share on other sites

Ошибка может возникать из-за языковых файлов, так как у меня на 3х версиях от ibr все хорошо.

Share this post


Link to post
Share on other sites

еще на заметочку. Надо исправить отображение названий тегов в теме, а то опять получается - белый текст по белому фону. Впринципе могу и сам это сделать, чуть позже выкину сюда как исправить.

 

ошибка может возникать изза языковых файлов, так как у меня на 3х версиях от ibr все хорошо.

 

На 3.3.0 не было такой проблемы. Стояла сборочка особенная и редактировалась все удачно. НО...

 

На 3.3.1 от IBR не канает, приходилось вручную исправлять.

 

Считайте, что вы сделали апдейт своего скина.

Edited by fortek

Share this post


Link to post
Share on other sites

Итак продолжу апать тему и проводить наработки. Имеем скин с большинством темных тонов. Но цвета фона тега были серого цвета. Покопавшись в CSS, а имеено в ipb_styles.css нашел блок

 

/* TAG LIST */

.ipsTag {
display: inline-block;
background: url(http://ipbskins.ru/forum/public/style_images/ipbskins/tag_bg.png );
height: 20px;
line-height: 20px;
padding: 0 7px 0 15px;
margin: 5px 5px 0 0;
font-size: 11px;
color: #656565;
text-shadow: 0 1px 0 rgba(255,255,255,1);
-moz-border-radius: 0 3px 3px 0;
-webkit-border-top-right-radius: 3px;
-webkit-border-bottom-right-radius: 3px;
border-radius: 0 3px 3px 0;
}

 

Файл tag_bg.png как раз и отвечает за наш фон тега.

 

Искать его в /Ваш_Форум/public/style_images/iriska/tag_bg.png

 

Берем фотошоп в руки и делаем палитру как вам угодно.

 

Вот готовый фон тэга в темных тонах, качайте кому надо - post-50290-0-49603900-1334873441_thumb.png

 

У меня получилось так:

 

3dee241382eb.jpg

Edited by fortek
  • Upvote 1

Share this post


Link to post
Share on other sites

И еще раз здравствуйте. Разработчик и автор скина явно не любитель смотреть и тестировать свою работу. Поэтому в роли техподдержки по скину выступлю я. Огромный косяк, был обнаружен когда я запустил Гугл Хром ( я сижу на Мозилле если что), все прокрутка форума тормозит ужасно, мне жалко стало пользователей моего сайта. Да тут конечно косяк самого автора, который в своем скине использует аццкие разрешения фонов в 1920 на 1280. Это якобы спасает от того что картинка не размножиться при выставлении фона, но она РАЗМНОЖАЕТСЯ. И я еще удивляюсь почему так все тормозит ужасно, картинка почти на 700 килобайт и по многу раз. FAIL!

 

Вот вам пример. Зажал Ctrl+ крутанул колесиком мышки на максимум.

 

Увидели? Вот и я о том же. Автор стыдно!

 

Значит я поставил перед собой задачу исправить этот косяк небольшой правкой CSS-кода. А именно.

 

АЦ > Настройки стилей > Iriska > Настройка шаблона и CSS > CSS > ipb_styles.css

 

Ищем вот это:

 

.bg1, .bg2, .bg3, .bg4, .bg5, .bg6 {
background-repeat: repeat-x;
background-attachment: fixed;
background-position: center 0;
background-color: #000000;
}

 

Удаляем, а точнее заменяем это недоразумение на:

 

.bg1, .bg2, .bg3, .bg4, .bg5, .bg6 {
background-repeat: no-repeat top center;
background-size: 100% 100%;
background-attachment: fixed;
}

 

И EPIC WIN - мы получаем должное с любым разрешением. Опять же скрин с прокруткой на максимум. На любом разрешении у вас будет меняться размер самого форума, но фон будет стоять на полное растягивание.

 

И гугл радуется даже.

 

Собственно столько недоработок было обнаружено мною. За что собственно я заплатил 200 руб, не особо понимаю. За такие косяки тут -100 рублей. Тут только плюс за прозрачность данного скина и выбор фона. Остальное - пили своими руками.

 

Заплатил за готовый к использованию продукт, в итоге получил солянку.

 

Пошел в поиски следующих недочетов, что увижу - выложу в эту тему.

 

А так скин лучше выкинуть в паблик, что изначально было сделано мною, но потом по просьбе автора удалил.

Share this post


Link to post
Share on other sites

обнаружена проблема что и с тегами и цитированием была, но только теперь с голосованием, завтра выложу фикс

Share this post


Link to post
Share on other sites

Обновление 2

- Исправлена ошибка с отображением фона тегов

- Исправлена ошибка с отображением фона форума

- Исправлена ошибка с отображением опроса

- Исправлена ошибка с тегом code

- Исправлена ошибка с диалоговым окном

- Добавлен бонус пак из 6 изображений на тему природы

Share this post


Link to post
Share on other sites

уважаемый fortek большое спасибо вам за помощь в выявлении ошибок, но не стоит себя брать так много :)

 

p.s.

Давно это ли

background-repeat:

может иметь параметры top center ? советую посмотреть

и зачем нужно было удалять ?

background-position: center 0;

это же было задано для выравнивания фона по осям.

 

На 3.3.1 от IBR не канает, приходилось вручную исправлять.

может уже пора обрать свой взор на это ?

Share this post


Link to post
Share on other sites

Приобрёл это шаблон. Однако при установке изображений они не загружаются и выскакивает сообщение: Сообщение IP.Board

Ошибка импортирования: Нечего импортировать!

Я и на хостинг закачивал, но ответ такой же.

Подскажите, как с этим быть?

версия IPB 3.3.1

Share this post


Link to post
Share on other sites

Попробуйте скачать версию 1.1 и из нее выдернуть изображения, если ошибка останится будем смотреть, так как ошибка может быть связана с тем что файл с изображениями очень большой и ipb его не может воспринять.

Share this post


Link to post
Share on other sites

В архиве со стилем идет ссылка на рапидшару с неким мануалом по установке. Но на самой рапидшаре он уже удален =(

Share this post


Link to post
Share on other sites

Помогите пожалуйста. Сначала установил этот фон на IP.Board 3.4.3 в процессе установки система сообщила что фон создан для IP.Board 3.3.2 и могут быть ошибки с более новой версией, я это проигнорировал и установил. Когда зашел в раздел Форумы сверху увидел следующие строки:

Warning: Illegal string offset 'p_start' in /home/u575125913/public_html/cache/skin_cache/cacheid_4/skin_forum.php on line 626
Warning: Illegal string offset 'id' in /home/u575125913/public_html/cache/skin_cache/cacheid_4/skin_forum.php on line 626
Warning: Illegal string offset 'id' in /home/u575125913/public_html/cache/skin_cache/cacheid_4/skin_forum.php on line 626
Warning: Illegal string offset 'seo' in /home/u575125913/public_html/cache/skin_cache/cacheid_4/skin_forum.php on line 626
Warning: Illegal string offset 'p_title' in /home/u575125913/public_html/cache/skin_cache/cacheid_4/skin_forum.php on line 626
Warning: Illegal string offset 'name' in /home/u575125913/public_html/cache/skin_cache/cacheid_4/skin_forum.php on line 626
Warning: Illegal string offset 'id' in /home/u575125913/public_html/cache/skin_cache/cacheid_4/skin_forum.php on line 626
Warning: Illegal string offset 'p_end' in /home/u575125913/public_html/cache/skin_cache/cacheid_4/skin_forum.php on line 626

Я подумал что это связано с несовместимостью и решил удалить 3.4.3 и установить 3.3.2, после установки ошибки остались хотя я создал новую Базу Данных и форум полностью чист, без хуков, групп пользователей и т.д.

 

Может кто знает как решить эту проблему?

Share this post


Link to post
Share on other sites

На локальном сервере с IP.Board 3.3.2 всё отлично работает. Я думаю что эти ошибки каким-то образом перенеслись с IP.Board 3.4.3 на 3.3.2. Но как? Я удалил форум (3.4.3), удалил Базу Данных --> создал Базу Данных, установил форум (3.3.2) а ошибки остались. Попробую ещё раз установить.

Share this post


Link to post
Share on other sites

Вопрос решен. Нужно изменить версию PHP на хостинге. У меня стояла PHP 5.4, а для этого скина нужно 5.2

Share this post


Link to post
Share on other sites
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...