Jump to content
Дизайн и модификация IPS Community IPBSkinsBETA
Search In
  • More options...
Find results that contain...
Find results in...
Sign in to follow this  
tikey

Zend Оптимизатор

Recommended Posts

ставлю ZendOptimizer

все выполняю по инструкции - а еффекта нет - пишет, не найден ZendOptimizer.

 

Дело в том что, какую правильно дирикторию выбирать при установке ZendOptimizer - ту где inetpub или ту де форум стоит?

Не так не так не помагает!

Share this post


Link to post
Share on other sites

Дело в том что, какую правильно дирикторию выбирать при установке ZendOptimizer

Windows?

 

- ту где inetpub или ту де форум стоит?

Не там где форум.

Share this post


Link to post
Share on other sites

Windows server 2008

IIS-> узлы -> мой узел (првязан к папке де стоит форум)

 

Никакой папки inetpub у меня нет в узлах, вернее была, но когда я ставил форум я сменил привязку на ту папку, де у меня форум.

В php.ini есть эти строки:

[Zend]

zend_extension_manager.optimizer_ts="C:\Program Files\Zend\ZendOptimizer-3.2.4\lib\Optimizer-3.2.4"

zend_extension_ts="C:\Program Files\Zend\ZendOptimizer-3.2.4\lib\ZendExtensionManager.dll"

 

 

 

Вот и задача - какую дерикторию выбрать для оптимайзера, на шаге установки после выбора php.ini ?

Edited by tikey

Share this post


Link to post
Share on other sites

Windows server 2008

IIS-> узлы -> мой узел (првязан к папке де стоит форум)

На IIS я не ставил Zend Optimizer. Но принцип везде одинаковый.

 

Вот и задача - какую дерикторию выбрать для оптимайзера, на шаге установки после выбора php.ini ?

Любую. Он сам ее пропишет в php.ini

 

В php.ini есть эти строки:

[Zend]

zend_extension_manager.optimizer_ts="C:\Program Files\Zend\ZendOptimizer-3.2.4\lib\Optimizer-3.2.4"

zend_extension_ts="C:\Program Files\Zend\ZendOptimizer-3.2.4\lib\ZendExtensionManager.dll"

Уже стоит или закоментированы?

Share this post


Link to post
Share on other sites

Они появляются, эти строки, именно тогда, когда при установке я указываю место, де стоит у меня директория php :)

 

Но вот вопрос мой так и не решен...

Share this post


Link to post
Share on other sites

Они появляются, эти строки, именно тогда, когда при установке я указываю место, де стоит у меня директория php :)

У меня стоит в www\apache\extensions\ZendOptimizer.dll

 

[Zend]
zend_optimizer.optimization_level=15
zend_extension_ts="extensions/ZendOptimizer.dll"

 

 

Но вот вопрос мой так и не решен...

Не понятна проблема. И не понятно отношение к данной теме.

Share this post


Link to post
Share on other sites

Ладно, буду пилить вопрос на поддержке данной проги.

И все же. В какой директории:

- сайт

- php.ini

- dll

у вас?

Share this post


Link to post
Share on other sites

Ладно, буду пилить вопрос на поддержке данной проги.

Перенесу в отдельную тему.

 

И все же. В какой директории:

- сайт

- php.ini

- dll

у вас?

Говорим только про windows.

 

1 инсталляция

C:\Bitrix Environment\www

C:\Bitrix Environment\apache

C:\Bitrix Environment\apache\extensions

 

2 инсталляция

W:\home\

W:\usr\local\php5\

W:\usr\local\php5\ext\

 

3 инсталляция

D:\www

D:\Zend\ZendServer\etc\

D:\Zend\ZendServer\etc\

D:\Zend\ZendServer\lib\optimizerplus\php-5.3.x\

Share this post


Link to post
Share on other sites

это вы о xp

а о win serv 2008? Там с директориями не такая каша :)

у меня:

Zend Optimazer: c:/program files(86)/zend/...

php.ini: c:/program files(86)/PHP/

сайт: e:/site

 

Эти папки я и прии установке зенда ставлю, но пишет что он не установлен, когда я пытаюсь мо наград ставить:

http://site.org/forum/awards_setup/

Edited by tikey

Share this post


Link to post
Share on other sites

это вы о xp

Да.

 

а о win serv 2008?

У меня боевые сервера стоят на FreeBSD и Debian. Не чуть не хуже, но зато все бесплатно.

Инсталляция на Windows Server 2008 всего одна. На старой работе. И то поднят не на IIS, а на apache. Что то под IIS я не нашел. Что не помню.

 

Там с директориями не такая каша :)

Это не каша, а 3 разных веб сервера на одной машине. Под разные задачи. На Windows Server 2008 под apache ставил похоже. В директорию program files не когда не ставлю "web службы".

 

Эти папки я и прии установке зенда ставлю, но пишет что он не установлен, когда я пытаюсь мо наград ставить:

Вот с этого и надо было начинать.

1. Пишем короткий файл php

<?PHP
phpinfo();
?>

Называем его как угодно и запускаем. Если он показывает, что-то типа

This program makes use of the Zend Scripting Language Engine:

Zend Engine v2.2.0, Copyright © 1998-2008 Zend Technologies with eAccelerator v0.9.5.2, Copyright © 2004-2006 eAccelerator, by eAccelerator with Zend Optimizer v3.3.3, Copyright © 1998-2007, by Zend Technologies

Значит все нормально. Иначе, криво поставили.

 

2. Если код закодирован под PHP 4x, а вы ставите на PHP 5. То естественно будет ругается на отсутствие Zend Optimizer.

Share this post


Link to post
Share on other sites

 

Вот с этого и надо было начинать.

1. Пишем короткий файл php

<?PHP
phpinfo();
?>

Называем его как угодно и запускаем. Если он показывает, что-то типа

This program makes use of the Zend Scripting Language Engine:

Zend Engine v2.2.0, Copyright © 1998-2008 Zend Technologies with eAccelerator v0.9.5.2, Copyright © 2004-2006 eAccelerator, by eAccelerator with Zend Optimizer v3.3.3, Copyright © 1998-2007, by Zend Technologies

Значит все нормально. Иначе, криво поставили.

 

2. Если код закодирован под PHP 4x, а вы ставите на PHP 5. То естественно будет ругается на отсутствие Zend Optimizer.

1.Файл стоит такой, и с помощью его я постоянно смотрю, решилась ли задачка - но тщетно - не устанавливается.

В чем кривизна? все по установке я описал выше.

2. Автор мода наград утверждает, что версия форума 2.3.4 и php 5 приемлим.

 

Решения не вижу. Тут речь уже даже не в моде, как в установке зенда.

 

Ph-A, с Вами посредством icq связаться можно? Буду очень признателен в помощи по решению задачи.

Share this post


Link to post
Share on other sites

а моде... Мод этот, отзывы позитивные...

Edited by tikey

Share this post


Link to post
Share on other sites

У меня возникла проблема с установкой Zend Оптимизатор Основная тема здесь.

Решение хотелось получить бы от компетентного и уважаемого активиста этого форума. Проблема вероятнее всего имеет частный случай, поэтому наберусь наглости просить на индивидуальный подход.

Share this post


Link to post
Share on other sites

У меня возникла проблема с установкой Zend Оптимизатор Основная тема здесь.

Слил две темы. Теперь все здесь

 

И удалите мод из сообщения. У нас нет разрешение автора на публикацию его мода на данном ресурсе.

 

 

P.S. Опять убегаю. Напишу позже.

 

2. Автор мода наград утверждает, что версия форума 2.3.4 и php 5 приемлим.

Автору можно верить

 

Решения не вижу. Тут речь уже даже не в моде, как в установке зенда.

Какая версия PHP у вас стоит?

 

Ph-A, с Вами посредством icq связаться можно? Буду очень признателен в помощи по решению задачи.

Вечером отвечу. Но я собаку ем на Linux. Знание Windows увы, не очень глубокие. IIS не знаю совсем

Share this post


Link to post
Share on other sites

Спасибо за надежду в решении проблемы, Ph-A.

Описываю до деталей, что к чему (может после этого тому можно будет и зачистить чуть-чуть :) )

 

1. У меня стоит собсвенный сервер, на котором стоит система Windows Server 2008 (Windows NT WIN-UEMTOI3TPH1 6.0 build 6002).

2. Версия IIS - 7.

3. Версия PHP - 5.2.13.

4. Директория, где лежит php.ini - C:\Program Files (x86)\PHP\php.ini

5. Директория, где находится сайт - E:\Site (Причем сайт составляет собой совокупность Mkportal и IPB v 2.3.4)

----------

Алгоритм действий: установка Zend Оптимизатора версии 3.3.3, скачанной с официального сайта.

 

При установке указал: путь установки:C:\Program Files (x86)\Zend\ZendOptimizer-3.3.0\

Путь к php.ini-файлу: C:\Program Files (x86)\PHP\php.ini

Путь к web-серверу: E:\Site.

----------

Имеется файлик, php info в директории E:\Site для мониторинга результата установки Zend Оптимизатора.

----------

После выполнения даной процедуры появляется запись в php.ini:

 

[Zend]
zend_extension_manager.optimizer_ts="C:\Program Files (x86)\Zend\ZendOptimizer-3.3.0\lib\Optimizer-3.3.0"
zend_extension_ts="C:\Program Files (x86)\Zend\ZendOptimizer-3.3.0\lib\ZendExtensionManager.dll"

 

----------

После установки, файл мониторинга не обнаруживает установленного Оптимизатора в php.

----------

Советовали добавить к коду строку:

zend_optimizer.enable_loader = 1

Добавил - но ни так, ни так - не работает...

----------

 

В чем может быть проблема и как ее устранить?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×
×
  • Create New...